2
$\begingroup$

When I navigate through the menu to Randomize and try to assign a shortcut, it doesn't take.

Trying to assign a shortcut manually isn't working either:

I've tried lots of different shortcut combinations, so I don't think it's a key conflict.

What could be the problem?

(Using Ver2.9.0)

$\endgroup$
8
  • $\begingroup$ Very strange. I just tried with 2.90 and 2.90.1 and it works for me. It doesn't show the shortcut keys in the menu but the shortcut works. $\endgroup$ – mugnozzo Sep 30 '20 at 7:12
  • $\begingroup$ Once you set the shortcut, do you try it in Edit Mode? $\endgroup$ – mugnozzo Sep 30 '20 at 7:25
  • $\begingroup$ what all combinations have you tried? $\endgroup$ – SHikha Mittal Sep 30 '20 at 10:13
  • $\begingroup$ @SHikhaMittal I've tried all modifier keys in combination with R. $\endgroup$ – Mentalist Sep 30 '20 at 11:12
  • $\begingroup$ Other things to note: I have the following enabled: Emulate Numpad, Emulate 3-btn Mouse, RMB to select (classic style). And I'm on macOS, so Cmd key is a thing. $\endgroup$ – Mentalist Sep 30 '20 at 11:15
0
$\begingroup$

So basically what you are facing is a shortage of appropriate shortcut options . You want to assign a shortcut which has R in it but you know that r is for rotating in all the modes , so you could've tried ctrl R but thats loop cut , alt R is clear rotation and shift r is repeat last action , so the final option is that you can go and add some other key like combinations of O for the shortcut because we are running out of shortcuts

$\endgroup$
1
  • $\begingroup$ I'm sorry, I had to un-accept your answer because although reassigning the shortcut to another key such as O did solve the problem for me (and thank you!), the reason you are giving for why Alt R doesn't work is incorrect. Consider this: Clear Rotation is exclusively an Object Mode command, and isn't possible to do in Edit Mode. Actually, Alt R and Ctrl Alt R are both unassigned in Edit Mode. To test this, I assigned Alt R to the Warp command and it works! so there is no clear reason why that shortcut can't be assigned to Randomize (yet Ctrl Alt O can). I'm still open to answers. $\endgroup$ – Mentalist Oct 1 '20 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.