2
$\begingroup$

inaccurate accurate

My image looks fine in the solid view, but get flattened and lose colors in the render view. Anyone know why this might happen?

$\endgroup$
6
  • $\begingroup$ which render engine you are using $\endgroup$ – Y-King Sep 29 '20 at 4:47
  • $\begingroup$ Also material setup could help. Check color management (unlikely, but not impossible) $\endgroup$ – Frederik Steinmetz Sep 29 '20 at 15:58
  • $\begingroup$ also also, if "use lights" is enabled there will be differences between solid and rendered view. But anyway, without more infos or a file it's pretty much impossible to work out what the problem is $\endgroup$ – wilks Oct 1 '20 at 17:02
  • $\begingroup$ I was using Workbench for render, but it didn't seem to make much a difference whether I switched to Eevee. I also played with 'use lights' to see if it made a difference. No success there either. Uploaded the blend if you'd like to check it out. Thanks for the responses! $\endgroup$ – YoJo Oct 5 '20 at 7:02
  • $\begingroup$ thanks for the file. actually after writing my answer i realised it's the same problem as in this question: blender.stackexchange.com/questions/196019/… $\endgroup$ – wilks Oct 5 '20 at 15:23
1
$\begingroup$

The problem: When in solid view there's no way of seeing if Vertex Colour mode is enabled or not. In your case it was enabled, which means that whatever material you used when drawing was being overridden by the brown colour selected for vertex colour. That only becomes visible when you switch to material preview or rendered mode.

The solution: I'm not sure there is an easy way to revert this. I looked but can't find a switch to disable vertex colours (whether at the object or layer level), which would be ideal.
So you could switch to Vertex Paint mode, select the same colour as your material (with the picker) and using the replace tool, fix every stroke's colour. This is gonna be long and tedious. You might be able to speed things up in some cases by isolating a layer and increasing the tool radius to do a whole layer at once. Also you can select everything that has a specific material by going in edit mode and clicking Select in the material panel.
A much simpler way would be to render the solid view with View > Render Viewport Animation. But then that limits what you'll be able to use in terms of effect and lights, as they won't show up in solid view.

Good luck and basically the advice is that in the future you should draw in Material Preview mode.


UPDATE: According to the following answer, as of 2.92 Alpha, there is an option in the Paint menu to Reset Vertex Color, which should solve this problem: https://blender.stackexchange.com/a/204738/168

$\endgroup$
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.