0
$\begingroup$

I made my grease pencil image (this lady) and did some fills: fills But now when I render out it goes weirdly green. green Any ideas what I might be doing wrong? I've had a look at my layers and they're all fine. I thought I may have a hue modifier on, but I have no modifiers.

$\endgroup$
1
2
$\begingroup$

I would hazard a guess that you've filled the character using vertex colour instead of material colour. Blender automatically sets the default vertex colour to that delightful shade of green you're seeing.

Vertex colour is only visible in Material Preview and Rendered view so it's likely you were in Solid view and may have set this accidently?

If you're not sure what I'm talking about, if you look at your first screenshot about midway at the top of the tool panel you'll see the offending green colour as the selected Vertex colour material. The settings pictured suggest the tool is set up to use material colour (the globe Icon) but it's probably likely when filling it was set the vertex colour?

To remedy you could go through and use vertex paint mode to recolour every point or just refill making sure the mode is set to material (globe turned on!).

Great drawing by the way! I hope that resolves your problem. Matt

$\endgroup$
3
  • $\begingroup$ I added a proposal to solve this kind of problems: blender.community/c/rightclickselect/h5gbbc $\endgroup$
    – wilks
    Oct 7 '20 at 9:33
  • 1
    $\begingroup$ That's a good idea. Personally I think Blender should just disable Vertex Color/Colour functionality in views where you can't see it's effects. I cant see that anyone would miss it in the modes its invisible anyway. $\endgroup$
    – Matt
    Oct 14 '20 at 22:32
  • $\begingroup$ yes, actually should have put in my proposal "grey out vertex paint in wireframe and solid mode" $\endgroup$
    – wilks
    Oct 16 '20 at 9:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.