0
$\begingroup$

I´ve imported a Dforce hair from DazStudio as a *OBJ and although it seems all is fine (other meshes work fine) the Hair mesh (multiple strands) always render black (Cycles and EEVEE)with any material i apply to it.

It doesn't matter what type of material i apply to it, simple or complex, it always render as pure black...

I´m kinda new to Blender as I'm in the first steps of learning it so, any light on the matter would be greatly appreciated!

Link to the sample file

$\endgroup$
2
$\begingroup$

This hair is not a "hair" made with Blender: Blender does not recognize it as hair. This is simply edges and edges cannot be shaded without faces.

Enter edit mode, select all A and give a very little extrusion E to the mesh (less than a millimeter or around that).

In the shader part, change the "hair BSDF" by a "Principled" shader.

enter image description here

$\endgroup$
1
  • $\begingroup$ Thanks for the tips. I tried that but with the Solidify Modifier... I really thought the solidify Modifier did the same thing as Extrude. Apparently i was mistaken :) Didn't know the Princpled Hair Shader Node was exclusively to use with Blender Hair Particle System too... That´s why I'm still a noob at Blender currently :) Anyway, thanks a ton for the answer! Take care! $\endgroup$ – Rui Vilarinho Sep 29 '20 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.