2
$\begingroup$

I'm trying to render an orange juice bottle, but the render appears to have z-fighting but render view doesn't, and I don't even know what could be overlapping. Both have 32 samples. The first image is the viewport, and the second is the render. I saw similar issue to this (the person was also rendering orange juice which is funny) but it was because their normals were facing the wrong way, but mine are right.

render view

render

$\endgroup$
  • $\begingroup$ I would say that looks more like a refraction issue, although I have no idea why it would be present in the render only. Do you have a triangulate modifier that is enabled for the render, but disabled for the viewport, or something like that? $\endgroup$ – Christopher Bennett Sep 28 at 9:07
  • $\begingroup$ @ChristopherBennett No, I never added a triangulate modifier. $\endgroup$ – Zero Sep 28 at 9:09
  • $\begingroup$ Yeah. I see that in the blend now. Any reason you're not using a Glass BSDF for your material? $\endgroup$ – Christopher Bennett Sep 28 at 9:10
  • $\begingroup$ @ChristopherBennett Transmission set to 1 in the principles BSDF node seems to work exactly the same. $\endgroup$ – Zero Sep 28 at 9:11
7
$\begingroup$

You have a "backup bottle" hidden in the viewport. Items hidden in the viewport will still be visible in renders. This is why you see Z-fighting. Either delete the object or move it to a separate (disabled) collection.

Bottle

| improve this answer | |
$\endgroup$
  • $\begingroup$ Agh thank you! Such a simple mistake! It's all good now. $\endgroup$ – Zero Sep 28 at 9:22
  • 1
    $\begingroup$ No problem. Sometimes it just takes a second set of eyes to spot the small stuff. Glad I could help. $\endgroup$ – Christopher Bennett Sep 28 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.