1
$\begingroup$

I'm making a new animation and for some reason, the lighting in the render isn't even.

I've tried adding an area light but no matter how bright it is, the dark faces on the right don't show any change.

It's all indirect lighting and with the symmetry, I want both sides would be lit the same way.

Here's a frame that shows what I'm talking about. (Surrounding the coin-op on the right hand side, it's all dark) uneven lighting

Any help is appreciated. I'm a bit stumped.

Edit: I've also noticed some splotches of darkness above the coin-op on the left. Could it be the texture?

Second edit: Link to file coming soon. Clamping and environment lighting did basically nothing.

https://drive.google.com/file/d/1mguxyLO8M8u8hAYRC3nFBJzHZht4XHMB/view?usp=drivesdk

Sorry it took so long to get my file uploaded! Hope this helps!

$\endgroup$
  • 1
    $\begingroup$ It is hard to tell without more information. Are you clamping any of the rays? Please show the render settings for light paths. Also consider uploading your file so others can inspect it and help you. $\endgroup$ – susu Sep 28 '20 at 1:47
  • $\begingroup$ I'm not sure what clamping rays means, so probably not. I'll update the post with a link to the file here in a little bit too! Thank you for the suggestion. $\endgroup$ – Vanessa Sep 28 '20 at 2:29
  • $\begingroup$ If you want even lighting you can try to enable the Environment lighting. $\endgroup$ – Y-King Sep 28 '20 at 2:36
  • $\begingroup$ Updated the post. Tried clamping and turning on environment lighting but nothing changed. $\endgroup$ – Vanessa Sep 28 '20 at 3:33
  • 1
    $\begingroup$ try changing the color management to filmic blender , and also have a look at the false color $\endgroup$ – SHikha Mittal Sep 28 '20 at 8:36
2
$\begingroup$

Difference in lightning does Material 2 - Magic texture. This node generates black material on some faces differently, depence on object position.

On the left side are black back sides of object on the right sides are black front sides of objects.

Disabling node from node tree fix the lightning issue.

enter image description here

Node attached into Normal socket generates blacks on all negative XYZ axis directions.

enter image description here

I don't know what is a proper way, but ussally you should plug node into Color socket. So try this.

enter image description here

Plus as already mentioned - you have overlaping objects with different materials. But even I kept only one side and Mirrored with modifier, issue was there.

$\endgroup$
  • $\begingroup$ That's helped the lighting but lost me the texture I was going for. Then the mirror modifier is flipping the text at the top of the cabinet. $\endgroup$ – Vanessa Sep 28 '20 at 16:42
  • $\begingroup$ Solution for that was duplicating, flipping 180, and then placing it in the right spot. $\endgroup$ – Vanessa Sep 28 '20 at 16:45
  • $\begingroup$ @Vanessa Can use another array modifier to mirror a part to the other side. Use object offset option $\endgroup$ – lemon Sep 28 '20 at 16:47
  • $\begingroup$ It's not exactly where I want this visually but your answer got me the closest to what I'm looking for. $\endgroup$ – Vanessa Sep 28 '20 at 16:54
  • $\begingroup$ Updated to some tip. You would need probably Texture Coordinates node and Mapping node as well. $\endgroup$ – vklidu Sep 28 '20 at 17:47
-1
$\begingroup$

Please Check your Materials. I guess you might have no specular with black base color in you Principled Bsdf node OR by accident you might have attached Black Emission in your shader output.

$\endgroup$
  • $\begingroup$ That was one of the first things I checked when troubleshooting and my materials all seem to be set right in material view. It's only when I switch to rendered that it turns black. $\endgroup$ – Vanessa Sep 28 '20 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.