0
$\begingroup$

I am using Blender 2.90.1 and I want to add that nice tiny bevels (so called brick seams) to a simple 1x4 LEGO brick (imported as OBJ file) using bevel modifier which doing its work very nicely with standard Blender cube (as seen in zillions of online tutorials about the bevel modifier).

But when I apply the same bevel modifier with the exact same values to the LEGO brick model, it extrudes edges of the LEGO brick erratically in all directions.

enter image description here

When I change the LIMIT METHOD to Angle and set it to 45° (or to any other angle) - as I need to bevel only edges under/above specific angle, it does nothing at all.

enter image description here

I guess there may be some sort of problem with the mesh defined inside the OBJ file, cos when I deleted all the faces except the side ones and re-apply the bevel modifier with amount value increased to 1m this is what happened:

enter image description here

For anyone willing to test it I uploaded the LEGO brick obj + mtl file to zippyshare here: https://www111.zippyshare.com/v/ZMN8UVNM/file.html

All the surfaces - cube and LEGO brick - are triangles.

My question is how to make the bevel modifier work with the LEGO brick mesh?

$\endgroup$
1
$\begingroup$

The topology is bad:

  • You have overlapping vertices, you need to select all and AltM > Merge By Distance.

  • Transform your tris to quads with AltJ

  • Your top cylinders are not part of your base cube, so there won't be any bevel on their bottom, you need to correct your geomatry if you want that.

  • Also their top and bottom are not perfect circle, select each circle and right click > LoopTools > Circle.

  • In the Properties panel > Object Data > Geometry Data, clear the Custom Split Normals Data to have correct normals.

  • Give your object the Bevel modifier.

| improve this answer | |
$\endgroup$
  • $\begingroup$ YES - this is it, at least the 1st half as I basically do not need that 2nd half of the answer right now but will look into it surely! Now the further problem is that there will be like 1000 such bricks in a model and I wonder: is there a way doing this procedure at once for all the bricks? As I cannot think of myself manually repairing every single one, you see. $\endgroup$ – qraqatit Sep 26 at 13:57
  • $\begingroup$ if your bricks are linked-duplications (Alt D), any change on one of them will be replicated on all of them. If they are different objects, select them all, select the good brick (the one you want to copy) at the end and press Ctrl L > Object Data, their mesh will all switch to the good one and they are now all instances $\endgroup$ – moonboots Sep 26 at 14:01
  • $\begingroup$ Thank you, but, well, I meant: there will be 1000 brick of different shapes (LEGO model) with this problem - is there a way how to edit all those different shapes with this solution at once (fingers crossed there is)? $\endgroup$ – qraqatit Sep 26 at 14:03
  • $\begingroup$ now with Blender you can select several objects, go in Edit mode, and make operations like merge by distance or tris to quads, in Object mode you can select several objects, then one last and Ctrl L to copy the modifier, so I think it's feasible, it completley depends on your computer capacity to manage a lot of vertices. $\endgroup$ – moonboots Sep 26 at 14:07
  • $\begingroup$ thank you so much: I will try that with the actual model + "Also their top and bottom are not perfect circle, select each circle and right click > LoopTools > Circle" - I did that but nothing happens, it still looks not rounded like a circle $\endgroup$ – qraqatit Sep 26 at 14:10
1
$\begingroup$

The obj file has most of its faces seperated by smoothing groups. Since they aren't connected the bevel modifier has no edges to work with.

To fix this, go into edit mode and select all vertices and use "merge by distance" to combine them.

The notches on the brick are rather low-poly so you might want to set the auto-smooth angle and bevel limit angle to at least 45° and use "clear sharp" to get better shading Brick with better geometry and shading

| improve this answer | |
$\endgroup$
  • $\begingroup$ your version look very nice and smooth, can you please provide the .blender file so I can see/learn what exactly did you do there to achieve this almost high-poly look? Cos I did what you said: increased auto-smooth to 45 and bevel modifier angle limit to 45 but my brick does not look as nice as yours. So: could you? $\endgroup$ – qraqatit Sep 26 at 14:01
  • $\begingroup$ sure: <img src="https://blend-exchange.giantcowfilms.com/embedImage.png?bid=pD2wKw9q" /> There are two versions in the file: one using the subdiv modifier (with more geometry) and one using weighted normals. The right way to create this brick would require joining the notches and the brick itself, but this sould be good enough for most purposes $\endgroup$ – Ismir Egal Sep 26 at 14:26
  • $\begingroup$ thank you million times - you just learned me a trick how to make low poly into pseudo-high poly! I mean the brick with the Subdivision, bravo! $\endgroup$ – qraqatit Sep 26 at 14:33
  • $\begingroup$ @qraqatit don't post thanks as a comment, if an answer helped you upvote it instead $\endgroup$ – Duarte Farrajota Ramos Sep 26 at 15:04
  • $\begingroup$ @DuarteFarrajotaRamos hardly: I do not have sufficient amount of reputation points thus I cannot upvote anything... $\endgroup$ – qraqatit Sep 26 at 15:06
0
$\begingroup$

Without seeing the wireframe of your LEGO brick, it is hard to tell for sure what is going on. Probably "Clamp Overlap"(under "Geometry") is on and limited the width of the bevel, at least when you used limit method = Angle. But beware that just turning off Clamp Overlap is unlikely to make you happy, because that option is there to prevent a bevel amount that causes overlapping geometry.

However if Clamp Overlap is the problem, then I am confused as to why you get a noticeable bevel with no limit method. So other things to check:

  • Are all the normals facing in the expected direction?
  • Are there any non-manifold edges? (In Edit mode, try Select All By Trait -> Select Non-manifold)
  • Are the tops of your circles triangulated in a way that makes it hard to do much of a bevel before overlap sets in? If so, you might want to make those tops into one big ngon.
| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi, I updated my post and added link with the LEGO brick obj test files I am using - hope it helps. $\endgroup$ – qraqatit Sep 26 at 13:15
  • $\begingroup$ So, I did test as you suggested by "Are there any non-manifold edges? (In Edit mode, try Select All By Trait -> Select Non-manifold)",and YES, there are some...so now what? $\endgroup$ – qraqatit Sep 26 at 13:44
  • $\begingroup$ In edit mode, select all, then alt+J to make quads when possible. Then M to merge by distance. Now bevel should do with a angle limit at 35 degrees. $\endgroup$ – lemon Sep 26 at 13:47
  • $\begingroup$ @lemon YES, exactly that - I just found out it myself via some external webpage, but if you post this as separate answer i will flag it as correct one (otherwise I will answer my question myself, I will wait a while). Now the question is: how to make it all at once if you have, let's say, 1000 of such bricks, hm? $\endgroup$ – qraqatit Sep 26 at 13:54
  • $\begingroup$ No matter for the answer, you have the solution. If 1000... can try to select them all enter edit mode and do the same... $\endgroup$ – lemon Sep 26 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.