This is a similar question to How to illuminate the darkness inside glass objects in Cycles? however, the answers there didn't solve my problem.

I have an object that is wrapped in an uneven thin foil (aka a sculptured cube with "Transmission 1.0"). I my shading viewport, it looks almost perfect, like it should be:

Shading Viewport

However, when I render it with Cycles, the result looks like this:

Final render

I turned Max Bounces Total, Transmission, Transparency, basically all the Light Path settings up and down but I don't get rid of those dark spots.

How can I get my render being closer to the output in the shading viewport?

This is the file. The image texture is missing but the dark spots caused by the foil are visible.


1 Answer 1


I think you've just forgotten to remove two object from rendering, thus the overlapping (I don't know why the render icon is not displayed by default though):

enter image description here

  • $\begingroup$ That was it! What a stupid mistake... thanks! $\endgroup$ Sep 24, 2020 at 14:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .