0
$\begingroup$

So I am trying to make a glassy transparent cup according to a tutorial but I seem to have misclicked something and now every default material when I change the viewport into preview material is the default forest one that comes with BLENDER 2.90. However, when I render the object with the camera it shows the way I want it.

I have tried removing the material from the cup or the liquid and adding a new one with the default white color. when I turn the Transparency to 1 and Roughness to 0 it becomes the forest HDRI again.

This is what I mean enter image description here

blend file: https://pasteall.org/blend/154d7b8156aa42bbb0c41dcb332a32ab

$\endgroup$
0
2
$\begingroup$

Preview and render use different render engines, that's why it looks different.
Just enable refraction in Eevee and both will look right.

  1. Properties > Material > Viewport Display
  2. Check Screen space refraction
  3. Specify Refraction depth (glass thickness)

More thorough answer: My glass material isn't transparent in Eevee

enter image description here

$\endgroup$
9
  • $\begingroup$ I am using Cycles render. I think its something wrong with the Scene world rather than the refraction. $\endgroup$ – Goop Sep 24 '20 at 7:19
  • $\begingroup$ Right :). But your viewport preview (the third icon) always uses Eevee. I don't think there's anything wrong with your scene, but you can share the .blend just to be sure. $\endgroup$ – Jachym Michal Sep 24 '20 at 7:25
  • $\begingroup$ I have tried your method but all I get is a lighter version of the forest material. imgur.com/5GH6y5Q $\endgroup$ – Goop Sep 24 '20 at 10:36
  • $\begingroup$ @Goop Yeah, you also need to enable refraction in Eevee render settings :). Follow the linked answer. $\endgroup$ – Jachym Michal Sep 24 '20 at 10:59
  • $\begingroup$ I did in both but it still looks off and is not working properly even though initially it did b4 adding the liquid and changing something. imgur.com/MwGKyWJ $\endgroup$ – Goop Sep 24 '20 at 11:22
0
$\begingroup$

This may be the reflect on this very shiny material (roughness = 0) of the HDRMI provided by Preview shading. If you tick Scene world in shading menu, or switch to Rendered shading it should disappear.

$\endgroup$
3
  • $\begingroup$ Changing to Rendered shading does not make it disappear. However, ticking the Scene world does make it look transparent but the whole 3d viewport world is bright white as opposed to the default grey. imgur.com/GxagJGy $\endgroup$ – Goop Sep 24 '20 at 7:16
  • $\begingroup$ In Rendered shading, you also have to tick Scene world in shading menu. You may have change world color in World properties for a lighter color. $\endgroup$ – loopkin Sep 24 '20 at 7:23
  • $\begingroup$ Does not seem to work as when I change the world color it changes the objects color to reflect that as well. like everything goes grey. I did tick the box in rendered shading and it still just makes that viewport full on bright white too. $\endgroup$ – Goop Sep 24 '20 at 10:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.