0
$\begingroup$

I am trying to make a rocket exhaust .dae/collada object for a trajectory software called AGI/STK. A muzzle flash would be the same thing. I can import a .png file with transparencies into blender without any issues. However, when I export a collada file I repeatedly get the same result of the transparency showing along with the picture.

I have tried Blender 2.7, 2.8, and 2.9. I have attempted to use Blender Game, Cycles, and Evee. I have tried to export directly, and I have tried to bake the texture. I always end up with the same result. Any help that will aid me in making the transparent portion of the .png file invisible, would be much oblidged.

PNG as seen in Blender

Screen capture of exported .dae/collada image in AGI/STKgur.com/zPApw.pngf

$\endgroup$
4
  • $\begingroup$ Recall something similar re export to three.js Try setting the alpha to not exactly zero, eg 0.001 $\endgroup$ – batFINGER Sep 24 '20 at 5:44
  • $\begingroup$ Is your problem with rendering in Blender, or with rendering elsewhere? Your Blender render looks okay. You need to be looking at material specifications for the renderer you're using. Materials are not necessarily cross-engine compatible, although some exporters try their best to make them so. $\endgroup$ – Nathan Sep 24 '20 at 7:52
  • $\begingroup$ batFinger... Is this the the alpha setting in "Materials" or in "Textures" that you are referring to? $\endgroup$ – Buck Sep 24 '20 at 13:59
  • $\begingroup$ Nathan...I actually was successful once with getting the result in blender (2.7), but I accidently deleted the file at a later time. I cannot retrace my steps. So, the renderer will show transparencies if the collada export is done correctly. This should be a stupid simple retrace of previous work, but Blender is so damn finicky, I cannot get the .da/collada file to export rcorrectly. $\endgroup$ – Buck Sep 24 '20 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.