0
$\begingroup$

I'm trying to model a cylinder (basket) on top of a wooden surface. For the material I use an emission shader with a picture image. Here's how the bowl material is set:

enter image description here

(The wooden surface is similar, both taken from a picture I have, using projection UV).

When I try to render that using Eevee, the results seem reasonable:

enter image description here

But when I switch to Cycles (my intended renderer), the materials are not shown:

enter image description here

What am I missing? I didn't use any special nodes or anything for this, but here's how the node graph for the basket looks like:

enter image description here

Thanks.

Context: I have a short clip I camera tracked, and I want to replace the surface and the basket.

$\endgroup$
1
  • $\begingroup$ If you're just emitting, there's really zero reason to prefer Cycles over Eevee. Beyond that, this is a situation where, personally, I'd have to see a file to say anything. The first things I'd look at would be other mats, render settings, world output. Probably the first thing to do is make a cube and see if it renders like your Cycles render (which doesn't look like a Cycles render, there's no noise, it looks like an ultra-filtered raster.) $\endgroup$
    – Nathan
    Sep 24, 2020 at 5:23

1 Answer 1

0
$\begingroup$

Thanks Nathan, your comment gave me the courage to dig deeper. Eventually, I found 2 issues.

  • Because the wood surface was actually generated as the ground when I used 'Setup Tracking Scene', it was set as 'Shadow catcher' in the Visibility section of the object properties.
  • When I added the cylinder, I added it to the 'background' collection, which was marked as 'holdout' in the same section.

Again, thanks Nathan for your tip, I added a cube above the surface, made it glossy and it rendered fine, which led me to that extra investigation.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .