2
$\begingroup$

I have Googled the heck out of this and am still not finding my solution.

I'm several hours into modeling a character and suddenly mirroring doesn't work. For any vertex. For any axis. I have restarted Blender and reopened the project to no avail.

I am able to create new Mesh cubes in the same Collection and mirroring works on them.

I am new to Blender so I maybe I simply hit a hotkey by mistake? I have no idea what it could have been if that's the case.

I have found answers online saying to "apply rotation," but this does nothing for my model. I have "applied" everything, all transforms. I haven't added a rig to it.

[Edit]: I have tried "snap to symmetry" on both the entire mesh and only half the mesh and neither works. Also, Sculpting in the sculpting tab works as expected. Still not working for modeling. It's like the functionality broke entirely or something.

[Edit 2]: When I "Add" a mesh to the scene in Edit mode, rather than object mode (so I technically add it to the character object), I am NOT able to mirror any axes on the newly added mesh. Only when I add a whole new object in Object mode.

[Edit 3]: Here's the .blend. The butt is lovingly modeled:

My project consists of 1 Collection containing 3 lights and my object. That is it.

Thank you!

Please let me know if there's any other information I can provide.

$\endgroup$
12
  • $\begingroup$ A couple of ideas: 1) Make sure there are no hidden verts/edges/faces in the mesh. In edit mode, show all with alt-H. 2) Make sure your object origin is where you want it for mirroring. If the origin is set to the 'center of geometry', mirror may give weird results. 3) Simple one: make sure mirror modifier is active. If it was working properly before, you might've just clicked it to inactive. $\endgroup$ – zippy Sep 22 '20 at 23:51
  • $\begingroup$ Thanks for the response. I'll address each point. 1) It does not appear to be showing any hidden verts. I have afterward used Merge By Distance and it cleans up 0 verts. 2) I have tried putting the origin at Global 0 and at the center of the mass of my character. 3) It is active. I have gone into the Sculpt tab and am able to mirror sculpts just fine, although obv I don't want to do that haha. To be clear: NOTHING happens when I mirror any (or all) axes. I can move/rotate/scale my mesh, but absolutely nothing is mirrored and the only thing affected are the verts I select. $\endgroup$ – stackMeUp Sep 23 '20 at 0:06
  • $\begingroup$ It sounds to me like the problem has to do with your origin. Mirroring happens along an object's local origin, so make sure the origin is at the edge of the "half" you want to mirror (not center of mass). $\endgroup$ – Christopher Bennett Sep 23 '20 at 0:26
  • $\begingroup$ But if this was the case, wouldn't something happen? No matter where I put the origin or what axis I mirror, literally zero mirrored transformations happen to anything, in any direction. I had the origin at the center of the object the entire time up until recently when it just abruptly stopped working, and it worked as intended the entire time. I'm talking about an entire humanoid character, almost complete, mirrored the entire time. And then, poof, mirroring broke. Like a cord was cut. To be clear I have tried moving the origin all over since it broke and not a single mirrored vert budged $\endgroup$ – stackMeUp Sep 23 '20 at 0:35
  • $\begingroup$ It's hard to tell without seeing your setup. Any chance you could post a minimal example of your .blend? You can do it here - blend-exchange.giantcowfilms.com $\endgroup$ – Christopher Bennett Sep 23 '20 at 0:39
1
$\begingroup$

In edit mode (TAB), select all vertices (A). In mesh menu, click "Symmetrize" to fix the symmetry (use -X to +X or +X to -X). It should be fixed if you use X as mirroring axis.
While all vertices are selected, you should also fix your normals with Shift + N.
You should also try mirror modifier (but you have to delete 1 side).

$\endgroup$
0
$\begingroup$

Maybe too late for you, @Bithur , but can help many others with the same problem.

Please check where the Object origin is. If the origin is on the centre of the object, the mirror modifier will land within the same object and the feeling is it doesn't work properly.

To check if it's not really working, apply the Mirror modifier in object mode and then enter edit mode, select all the vertices and move the object G. As soon as the mesh is moved from its object origin in edit mode, you will see the mirror applied.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.