1
$\begingroup$

Sometimes I need to tweak a video recording made in Zoom. According to Zoom, it is an MP4 with M4A audio after conversion (the raw data is, I think, some propriety raw data). However, a 13 minute Zoom recording resulted in 91MB after converting (within Zoom).

When I made my edit (silenced audio for 1 second where I cursed oops), the rendered output from Blender was 471MB!!

I have tried reducing the audio sampling (32 instead of the 192 default) and the result was still several hundred MB. I tried removing the audio entirely and the output was about 150MB, still significantly larger. The recording is a full-screen (2880x1800) so as is the Blender output.

I feel like I'm missing something. I realize Blender doesn't output M4A, but I can't bring myself to believe an AAC or MP3 track should result in a file 4-5X as large.

FYI, I'm using Blender 2.79, but I get similar results in 2.83.1.

Ideas?

-C64Whiz

Edit 2020/09/22: I tried the 'ffmpeg' solution offered up by @Husch and the resulting file was 55MB smaller!!!! WTH? I cut out 1 second of audio, that was it!

Also, I tried again in Blender 2.79 after "Factory Reset" and no audio rendering...and still much larger than the original zoom MP4.

I've downloaded Blender 2.90 (Linux), cleared out all Blender settings I could find in my home dir (including within .config, .share, .etc) and tried rendering with no special settings: after 2% done I already had 10MB of data. Extrapolate and the final file would be over 500MB...i.e. no change.

I will say this, I keep having to set the render resolution to 2880x1800 as the default even after I add the video to an empty sequencer. I don't "import" a video. I "add" one; could this be an issue??

Edit 2020/09/23: Attempted a fresh install of Blender 2.90 on Debian 10 (though a slow 2-core system), and didn't modify the added video...just rendered with settings allegedly identical to the source. Resulting render was 511MB, ~5X the original 95MB Zoom file. I repeated the render changing only the % of the resolution setting to 50% (X,Y was still 2880x1800). Resulting file size was 178MB.

To @susu's comment about compression, I have it set for MPEG-4 container, Video codec H.264, Medium Quality, Good Speed, and audio AAC codec, mono, and 32000 sample rate, 192 bitrate. The codecs are the same as the source as indicated by 'exiftool', as is the 32000 sample rate. Not sure about the 192 bitrate and obviously no clue about the video quality level and encoding speed...

...then I did some investigation and found the source, according to 'exiftool', uses 16 "Audio Bits per Sample". So I tried changing Blender's 192 default bitrate for audio to 16 but it won't let me go any lower than 32...so I kept it at 32. Resulting rendered file size with Resolution % back at 100% - 494MB.

Sound doesn't seem to be much of a factor but I can't understand why I have to set Video % to 50 when the original shows no indication of it. (Honestly, I don't even know what % means if the resolution is X,Y.)

I'm stuck. :(

$\endgroup$
3
  • $\begingroup$ The size of the file will depend on the compression settings (codec, data rate, number of channels of audio, etc) $\endgroup$ – susu Sep 22 '20 at 21:42
  • $\begingroup$ In ffmpeg use the copy stream flag 'c:v copy' so that the video portion is not re-encoded, but just copied. $\endgroup$ – susu Sep 22 '20 at 21:53
  • $\begingroup$ video.stackexchange.com/questions/29258/… $\endgroup$ – susu Sep 23 '20 at 14:33
0
$\begingroup$

I've tried to import a zoom-recording (downloaded from the internet; 53MB) in Blender 2.91 and the rendered output file from Blender was only slightly larger (55MB). Maybe you can try version 2.91?

However, if your only need is to silence some part of your video, then you can easily/fast do it with ffmpeg. The command is as follows (all on one line):

ffmpeg -i zoom_0.mp4 -af "volume=enable='between(t,0,10)':volume=0, volume=enable='between(t,20,30)':volume=0" zoom_silenced.mp4

The input-file is zoom_0.mp4. The output-file is zoom_silenced.mp4. Two periods are slienced: from second 0 (begin) to second 10 and again from second 20 until second 30.

You can find more information at: https://stackoverflow.com/questions/29215197/mute-specified-sections-of-an-audio-file-using-ffmpeg. There are also lots of YouTube-tutorials on how to install ffmpeg.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.