0
$\begingroup$

I created simple rooms with planes and cubes by Blender 2.83 and exported it as fbx file.

enter image description here

Then I imported it into Unity, and its inner walls are transparent.

enter image description here

Why? Will anybody help me resolve this? Thanks.

$\endgroup$
  • $\begingroup$ Backface culling. Don't know if possible to avoid it in Unity. But if not, solidify the model in Blender. $\endgroup$ – lemon Sep 21 at 20:32
  • 1
    $\begingroup$ Thanks a lot for your reaction! $\endgroup$ – gogogogogo Sep 21 at 20:53
0
$\begingroup$

The reason you're seeing this effect is that in game engines like Unity, typically only one side of every face is rendered. Faces have a front and a back, and only the front of a face is rendered. This is typically done because in many circumstances, the back sides of faces are never seen, and it is much more efficient to never render them.

To better preview what your mesh is going to look like in Unity, you can turn on Backface Culling in Blender.

enter image description here

If you do need a face to be visible from both sides in Unity, you can duplicate that face in Blender, and flip the normals (the direction the face is pointing) by pressing ALT+N, then F.

Typically though, real life objects (like walls) aren't infinitely thin, so you will usually have a face defining either side of a wall, with some distance in between.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for the detailed explanation, I will try that! $\endgroup$ – gogogogogo Sep 21 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.