3
$\begingroup$

Sorry, my English skill bad. I'm new to Blender. I have a steel barrel but in Eevee Render it look like shadow error, light pass through steel barrel. I don't want that. enter image description here. Anyone can explain for me why? And how to fix this problem or I missing something in model progress. Thanks !

$\endgroup$
  • $\begingroup$ Sorry, I just saw you said this happens in Unity as well? Try selecting the whole mesh (in edit mode), and select mesh > clean up > merge by distance. Also try mesh > normals > recalculate outside. $\endgroup$ – Christopher Bennett Sep 21 at 9:38
4
$\begingroup$

Select your light, and under Properties, check the box that says "Contact Shadows".

Lightbleed

As you can see, however, a small amount of light still bleeds through. If this happens, it can usually be eliminated by giving your object more thickness. In the example below, I used a solidify modifier to make it thicker.

Nobleed

It seems like the only problem areas in your object are concerning the "bands". Make sure they have both inside and outside faces, and that they are correctly aligned with the rest of the mesh.

Lastly, though I cannot tell from your photo, it looks like your object may be mirrored on the Z axis. If this is the case, make sure the two halves merged correctly, and if you're using a modifier to achieve this make sure "Clipping" and "Merge" are enabled.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Yeah, make it thicker maybe good enough.I put it into Unity and get same problem lighting, i'll try your solution. Thankyou so much $\endgroup$ – bkm5 5 Sep 21 at 9:40
0
$\begingroup$

Eevee handles light very badly because it fakes it , on the other hand , cycles is a pro at lighting , you should really use cycles , if you want accurate lighting

| improve this answer | |
$\endgroup$
  • $\begingroup$ Sure, in Cycles it normal. But I put it into Unity and this get same problem $\endgroup$ – bkm5 5 Sep 21 at 9:35
  • $\begingroup$ Sorry but i dont have much knowledge about Unity , maybe this could be a problem with the game engine itself $\endgroup$ – SHikha Mittal Sep 21 at 9:38
  • $\begingroup$ Thankyou, it look like my object too thin, so blender and unity get same problem. $\endgroup$ – bkm5 5 Sep 21 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.