0
$\begingroup$

I exported my finished model + animations to Unity, but some parts of the model ended up being a bit deformed. I tried to redo the UV map and normalize the normals, but none of them worked. I'm stumped.

enter image description here

*How it looks like in Unity

enter image description here

*How it looks like in Blender

$\endgroup$
1
  • $\begingroup$ just noticed that if I export it as a .obj and not as a .fbx, its fine, it just doesnt export the animations, which isnt what i want. $\endgroup$
    – ItsWorth1T
    Sep 21, 2020 at 2:53

2 Answers 2

0
$\begingroup$

So I tried a different version of FBX before I exported it, and it seemed to work.

enter image description here

*I used FBX 7.4 binary before this

enter image description here

Now it looks like this in Unity

Honestly, I was just randomly trying different things, so I'm going to say that I have no idea why a different version of FBX fixed my problem.

$\endgroup$
0
$\begingroup$

Check “Selected Objects”>> At the right bottom, open the “Armature” settings and check “Only Deform Bones”, uncheck “Add Leaf Bones”>> At the right top shift-select “Armature” and “Mesh”

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .