0
$\begingroup$

Ok, I have several scaling animations synced to audio via "Bake sound to f curves" and I've applied an envelope modifier to control the max value the curve can hit. The curve looks like this -

enter image description here

This results in a pretty jumpy animation due to the jagged nature of the line or maybe the easing of the curve itself. Tried changing interpolation mode but this did nothing.

How can I smooth out the animation produced by "bake sound to f curves" ? Is this addon relevant How to change timing of my mocap BVH and how to optimize keyframes ? Or is it in the easing settings?

$\endgroup$
3
  • 1
    $\begingroup$ it's always tricky to do anything with baked curves. check this answer: blender.stackexchange.com/questions/19357/… $\endgroup$
    – wilks
    Sep 21 '20 at 13:17
  • $\begingroup$ @wilks perfect, this works. My only issue is I dont know how to apply my f curve modifiers before I unbake the curve $\endgroup$
    – skyguy
    Sep 21 '20 at 20:44
  • $\begingroup$ then i think you need to apply the f-curve modifiers with Bake Curve (Alt+C) then delete the modifiers, then unbake. but might be better to add your modifiers as the last step instead, that would give you more flexibility later $\endgroup$
    – wilks
    Sep 21 '20 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.