0
$\begingroup$

So Blender Devs were working on a cool feature of Workbench engine, that is rendering sharp shadows. They are rendered in the way that SketchUp viewport or ArchiCAD and some other CAD-like programs use, which is OpenGL shading (correct me if I'm wrong). Shadows are cast precisely, and they use vector methods to display terminators. Sneak peek was posted here: https://www.blendernation.com/2018/05/03/blender-2-8-code-quest-new-shadows-in-the-workbench-engine/#comment-913693

Anybody knows if this feature is available and how to turn on Workbench shadows?

$\endgroup$
1
$\begingroup$

This feature can be enabled both for the viewport and a final render with the workbench engine.

When the render engine is set to Workbench the option can be found in Render Properties > Options > Shadow.

Workbench Shadow

When the Viewport Shading is set to Solid, the same option is available for the viewport.

Viewport Shading

$\endgroup$
6
  • $\begingroup$ Cool! Thank you very, very much :D $\endgroup$ – michalpe Sep 19 '20 at 14:56
  • $\begingroup$ Doing this gives me self shadows but doesn't cast shadows. You guys get cast? $\endgroup$ – wilks Sep 19 '20 at 15:00
  • $\begingroup$ @wilks Yes, for instance adding a plane as floor will have shadows cast on it from objects located above. $\endgroup$ – Robert Gützkow Sep 19 '20 at 16:28
  • $\begingroup$ @RobertGützkow Right, worked it out, looks like it stopped working in 2.91alpha, well at least my version from 3 weeks ago =D It works fine in 2.90, cheers! $\endgroup$ – wilks Sep 19 '20 at 16:45
  • $\begingroup$ @wilks You're welcome! Should be fixed since since 28th of August (see T80160). $\endgroup$ – Robert Gützkow Sep 19 '20 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.