0
$\begingroup$

With: Eevee, 2.8.6, 2.9.0, macOS 10.15.4, Radeon RX 580.

My Temporal Anti-Aliasing is quite bad, it's very anoying. My TAA is good for meshes through to Film>Filter Size parameter.

If I put "1" to "Anti-aliasing Threshold" it's much better than "0", but not enough. If I try more than "1", it doesn't change anything, it doesn't blur the GP, even if I put "1000". I've tried to increase Sampling>Render, without success.

In "Hero" by Pepe Land, I can see there is no flickering due to aliasing, so it must be possible.

Here is my file, thanks!

:-)

Link to my file

$\endgroup$
1
  • $\begingroup$ Since I am not receiving a response, maybe I'm not clear. Is it possible to get a grease pencil animation without flickering due to aliasing? If yes, how? When I increase Eevee "Anti-aliasing Threshold" parameter it doesn't work beyond 1. Is it normal, am I experiencing a bug? Thanks in advance. $\endgroup$ – loopkin Sep 22 '20 at 10:42
1
$\begingroup$

There was a bug with Anti-aliasing in pre 2.9 versions. Are you up to date?

If you're experience flickering lines when moving the camera or an object then this is a known bug. I believe the fix at the moment is render in double the size and then compress. This works for me but naturally takes significantly longer to render.

Thanks Matt

$\endgroup$
4
  • $\begingroup$ Thanks for your answer! Yes, I've this flickering with 2.8 and 2.9 and yes my camera is moving, so this is a known bug? I've tried your workaround: export in UltraHD, and from there another export in FullHD from Blender VSE. But the flickering is still there... Is there some anti-alias settings in the VSE that I missed? Do you down sample with an other video editing soft? Thanks in advance! $\endgroup$ – loopkin Oct 2 '20 at 9:44
  • 1
    $\begingroup$ Unfortunately yes. When either an object or the camera moves Blender struggles with Stroke thickness which produces that horrible flicker. The thinner the line work the worse the flicker. Is it just strokes that are flickering? Usually I find the work around works for me. Do you have very thin line work perhaps? $\endgroup$ – Matt Oct 3 '20 at 8:14
  • 1
    $\begingroup$ Blender does see to flicker in a consistent way so I've seen some users go through their render and identify which frames flicker. They then move the flickering object the tiniest fraction in the opposite direction of the movement. I've found that to be hugely time consuming so I use thicker lines to be honest with you. $\endgroup$ – Matt Oct 3 '20 at 8:23
  • $\begingroup$ Yes the thinner my strokes the worse the flicker. My strokes are thick enough already... I've tried your workaround, but it doesn't work for me. My workaround is either to add noise modifier, when possible, to hide it, or to export GP in png and re-import it with image as plane :-) But for cut-out animations you loose the great possibilities of GP :-( $\endgroup$ – loopkin Oct 5 '20 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.