0
$\begingroup$

I have a cup that I made and I'm trying to move the bottom part along the z axis. I click on the edges using alt + click and press g and then z to move it, but when I do that, the bottom is able to move up and down but it ends up moving it in a really weird way (it moves toward my direction and up/down). What setting do I change so that I can fix this?

The object has a solidify and subdivision surface modifier attaches but removing them doesn't change anything so I don't think that has to do with this. This is what happens when I try to move the bottom along the z axis while facing the cup enter image description here

$\endgroup$
7
  • $\begingroup$ could you please share your file? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Sep 15 '20 at 7:28
  • $\begingroup$ Maby it has something to do with "Transform Orientation" or maby even a simple Keyboardlayout-Language-Changeup (engl. <> eu) $\endgroup$ – A M Sep 15 '20 at 8:11
  • $\begingroup$ I think you're moving along the local z axis, not world $\endgroup$ – Frederik Steinmetz Sep 15 '20 at 10:10
  • $\begingroup$ If you want to move the entire thing in edit mode, why not just press A to select all? $\endgroup$ – Eric Xue Sep 15 '20 at 13:28
  • $\begingroup$ @EricXue I'm trying to move the bottom of the cup so that it touches the ground, while keeping the top of the cup in the same place as the reference. I managed to move it down though but the problem itself isn't solved $\endgroup$ – KI. Sep 15 '20 at 15:50
1
$\begingroup$

I downloaded the file. When I went into Edit Mode, I couldn't select anything for some reason, so I wasn't able to test your exact problem, but I noticed that in Object Mode the whole cup does exactly what you're describing, and I figured out why it's doing that, and it would affect Edit Mode transformations as well.

You have snapping turned on; that's the magnet button up at the top of the viewport. That is constraining the selection to your floor plane. So you're trying to move it in the Z axis, but that is exactly what it cannot do while it's set to be snapped to the floor plane, and so it just moves in whatever axes it can. Turn off snapping, and it behaves normally.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.