2
$\begingroup$

I'm trying to export a character animation from Blender to Cinema 4D Lite. I've tried several exports, but I have been unable to have the animation come across. I'm afraid it has something to do with Cinema 4D Lite's lack of character animation tools (they're only available on the full, non-lite versions).

I'm new to Blender and tried some tutorials on baking the animation, but I'm not sure I'm doing it properly. I'm fine with not being able to edit the bones in Cinema, I just need the mesh to be animated.

Could someone lend a hand, or point me in the right direction?

Thanks!

$\endgroup$
2
$\begingroup$

I would use either COLLADA or FBX.

COLLADA

Copy these setting exactly. They can be found on the bottom left when you choose what to call the file.

enter image description here

Overview of settings

  • Apply modifiers: Applies any modifiers like subsurf, generally a good thing since your mesh could end up different on the other side
  • Selection Only: If you have a hole bunch of other stuff in your scene, this can be useful to limit which objects you send.
  • Texture Options: Allow you to send textures.

  • Deform Bones Only: Removes all bones that don't influence a mesh

The rest of the setting are irrelevant

NOTE: You can only export Euler rotation, not Quaternion.

FBX

The default options work, just make sure you have Armature selected:

enter image description here

More Options:

Simply try each one of these the C4D Lite supports. Make sure to include animation + armatures in the setting in the bottom right hand corner (like mentioned above).

enter image description here

$\endgroup$
  • $\begingroup$ I really appreciate your response. I tried both methods listed above and neither seemed to work. The COLLADA file imports, but it doesn't seem to grab the animation, just the current frame. The FBX import give an error in C4D "Unable to read file". I've uploaded the file, if you want to take a look. Again, I fear this is a limitation of C4D Lite dwdigitaldesign.com/duderigged.blend1 $\endgroup$ – Dustin Dec 2 '14 at 20:38
  • $\begingroup$ Apparently I linked the wrong file. Proper link should be: dwdigitaldesign.com/duderigged.blend $\endgroup$ – Dustin Dec 3 '14 at 14:03
  • $\begingroup$ @Dustin You will need to ask on a C4D Lite forum, I can't help with it since I don't own it. These exports have worked for other software... So it is probably an issue C4D light. $\endgroup$ – GiantCowFilms Dec 3 '14 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.