0
$\begingroup$

I'm having issues with Undo locking up Blender on the first undo action following some action. This happens whether I remain in one mode, or on one obj. Basically say I rotate a joint and I don't like it. I undo and my blender locks up for like 6 seconds then performs the undo. If I want to undo further from there I can get like 4 or 5 more in before it locks up again. And if I commit any new action, the first undo will always lock up.

Right now all I have in my scene is a few disabled duplicate collections (for safety), a retopo'd character body mesh (10K polys), a rigify rig, and an empty. my blend file is 37mb. Blender says the scene is using 3.3GB of Memory and 3.4GB of VRAM.

I am using global undo (tried without too). was at 200 undo steps with no limit, then tried at 50 step to see if that helped, but it didnt.

Any ideas? Am I missing something?

Thanks. Also, I dont see where I can add a blend file. is that not a thing? enter image description here

$\endgroup$
  • $\begingroup$ You can use Blend-Exchange, this site is for BSE only. $\endgroup$ – HikariTW Sep 14 at 1:16
1
$\begingroup$

If you encounter any problem toward Undo system, please help to file up that bug to the bug tracker in Blender develop. There is a new undo/redo system been adopted due to the old one was bulky in some situation.


A quick way to fix your strange behavior is to use old system instead of new one:

By checking Developer Extras in Preference-

enter image description here

And choose Experiment panel and check undo legacy

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Not sure if it was the legacy pref or just having restarted Blender and clearing the cache but it appears to be smooth now. Thanks for that tip $\endgroup$ – Jay Purrington Sep 14 at 3:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.