0
$\begingroup$

When I tried to make toon shading, with diffuse bsdf, shader to RGB, color ramp, and material outputs nodes, it appears to be fine if there is no object covering it with shadow(with only light emit and create the shadow)

enter image description here (the light is near the floor)

but when there is something blocking the object and create a shadow depend on where the light, it will appear with some gradient

enter image description here enter image description here (the light is behind something, causing the floor to have gradient)

enter image description here (my render properties)

all object have the same nodes, only diffuse, shader, color ramp, and material output.

$\endgroup$

1 Answer 1

0
$\begingroup$

Go into the Render Properties tab, and under Shadow, turn off (un-check) "Soft Shadows". Also, consider enabling high-bitdepth, and if the shadows have jagged edges, you can get rid of them by increasing the shadow-map Cube Size.

ToonShadows

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.