0
$\begingroup$

I moved around some of my blender files by putting them in a new folder ("failed tests") and now blender seems unable to navigate to any new files in the initial open file screen. I can open a file it has on the recent files list, but when I go to "open.." to navigate to another file, the file browser that opens up there won't let me click on any files other than whatever file I've opened last. If I go into the place where I can write the file path I can tell it to get to a specific file, but even then it's having problems with those files: it won't select anything in object mode. Any ideas what on earth is happening? I reinstalled Blender but the same thing is going on...

Edited to add: I can use the file path to get where I want to go, but I'd rather be able to double click on files in the file browser window: any idea why I can't? file browser

$\endgroup$
  • $\begingroup$ Okay. After much fussing and reinstalling I deleted my user preferences and that fixed everything... $\endgroup$ – Sam Simpson Sep 11 at 18:35
  • $\begingroup$ Sure, happy to. I'm on a mac. First I followed the instructions to show the hidden files on my hard drive like the ones on this link: (setapp.com/how-to/…) . After that I went to my hard drive, then users/(my username)/ Library/ Application Support/ Blender/ 2.82/ config/ and then I dragged the preferences file to the trash and emptied it. I restarted Blender after that and everything works fine now. $\endgroup$ – Sam Simpson Sep 13 at 1:02
2
$\begingroup$

There is a file called recent-files.txt that is saved where the config files are. If you edit that with the new paths you should be fine.

For the location of the file refer to this post:

Where is the startup file stored?

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you. That seems to reflect the recent files, which is good, but what's odd is that I can't double click on any folders to open them in the file browser... Any idea why that's happening $\endgroup$ – Sam Simpson Sep 11 at 17:16
0
$\begingroup$

Problem solved. I'm on a mac. First I followed these instructions to show the hidden files on my hard drive: in Finder, open up your Macintosh HD folder. Press Command+Shift+Dot. Your hidden files will become visible. After that I went to my hard drive, then users/(my username)/ Library/ Application Support/ Blender/ 2.82/ config/ and then I dragged the preferences file to the trash and emptied it. I restarted Blender after that and everything works fine now.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.