1
$\begingroup$

Hello blender community,

After exporting a model in GLB 2.0 format and loading it in three.js only part of the faces are being rendered. Displaying only the wireframe of the model works and the triangulation can be seen.

When I explicitly triangulate the model in blender and then export it, everything is being displayed correctly, but I want to work only with quads in blender and let the export function do the triangulation. And as one can see it works, but not on all parts of the mesh.

model

My assumption is that my model is not prepared correctly for the export. Although I did 'merge by distance' and 'degenerate dissolve'. Does anyone have any idea why only part of the model is "working"?

Best Wishes,

James.

$\endgroup$
2
  • $\begingroup$ Are the normal vectors correct? Maybe try Mesh -> Normals -> Recalculate Outside, see if that does anything. $\endgroup$ – emackey Sep 9 '20 at 13:37
  • $\begingroup$ Thank you for your suggestion. Recalculating the normals and updating blender to latest version seems to have fixed the problem. Now I can work with quads and the triangulation is done by the exporter. $\endgroup$ – timespace Sep 9 '20 at 15:13
0
$\begingroup$

Per comments above, the solution was to recalculate the normals, and upgrade to the version of Blender.

In the screenshots, it looks like some polygons face the camera, while others face away. If "Backface culling" is turned on (as a material property setting in Eevee), glTF will treat these polygons as single-sided, and may not render the ones facing the other way. The fix could be as easy as Mesh -> Normals -> Recalculate Outside, to get them all to face the same way. But if they need to be visible from both sides, make sure "Backface culling" is turned off under Eevee's material settings (not to be confused with a viewport option by the same name, that will have no effect on glTF export).

Also, Blender 2.90 includes several fixes to the glTF exporter, some related to normal vectors, so upgrading is recommended.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.