4
$\begingroup$

I am creating procedural clouds in Blender Cycles as shown in this tutorial: https://www.youtube.com/watch?v=Ba18cwDSAsk

After that, I would like to create a series of them, so as to generate a tileable picture, using an addon from stuffmatic

The problem I am encountering is that the procedural cloud material is still "opaque" somehow, it blocks the view from the cubes in the background, as seen in the attached screenshot.

http://williamjohnson.eu/Stack_Exchange_imgs/procedural_clouds_opaque.png

I played around with the nodes, tried to put a Translucent and/or transparent node in the "surface" output of the shader, but it didn't work. I also tried masking the cube somehow to keep only the volume but I didn't succedd either... Also tried changing some camera and rendering options but didn't help either.

It sounds strange that volume only materials have opaque surfaces, anyone had this problem before ?

Any hints are welcome :) Thanks for your help.

$\endgroup$
  • 1
    $\begingroup$ Can you upload a .blend to pasteall.org/blend $\endgroup$ – Nathan Craddock Nov 30 '14 at 16:06
  • $\begingroup$ Done, the file is called "procedural_clouds_01.blend" $\endgroup$ – william.johnson Dec 1 '14 at 9:41
  • $\begingroup$ We need a link for the pasteall file, you can't search by filename. What transparent depths do you have under Light Paths. This video may help $\endgroup$ – sambler Dec 1 '14 at 10:20
  • $\begingroup$ pasteall.org/blend/33150 $\endgroup$ – william.johnson Dec 1 '14 at 15:20
  • $\begingroup$ Thanks for the video link :) I watched it, but this applies to Surface output materials, so not exactly my case. Learned something in any case :) $\endgroup$ – william.johnson Dec 1 '14 at 15:37
4
$\begingroup$

I noticed that all of the cubes had faces that were in exactly the same place, so I moved every cube around until none of them were touching. This could also be done by selecting each cube, setting the pivot point to individual origins and then scaling down slightly.

After that, it rendered as expected.

clouds

Just avoid having the faces of a mesh that has a volumetric shader applied in the same place. Intersections of the objects are fine though.

clouds2

One more thing that I found is that you had many cubes that had an identical cube in the same place, so just avoid doing that. My render had some darker clouds because of that.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.