1
$\begingroup$

I'm trying to add hair to my model in Blender, but when I try to make the hair emit from only one place by using the tools in "Object Data: Vertex Groups" or by using Weight Paint, the hair doesn't move to where I painted, but stays in the same place. I tried using both version 2.67 and 2.72. What am I doing wrong?

$\endgroup$
  • $\begingroup$ You need to set the Particle System such that the Vertex Groups affect the density of hairs. On the particle system tab, scroll down to the subsection Vertex Groups and add your group to the density. $\endgroup$ – someonewithpc Nov 30 '14 at 13:10
3
$\begingroup$

Assign the selected vertex group and name it. enter image description here

Go to the 'Particles Menu' header and input the vertex group name in the Density window (located in 'Vertex Grops' panel). enter image description here

Edited:

I've checked your model and found the solution. In your case you have to place the 'Particle system' modifiers over the 'Mirror' modifier. As you can see below, the beard and tail particles are now assigned to the right vertex groups. enter image description here

I can advise you few more things. Before adding the hair particles to your model, make sure that:

  • it has a good topology
  • the double vertices are removed (in 'Edit Mode' press W--> Remove Doubles)
  • the normals are facing the right side (CTRL+N in 'Edit Mode')
  • the location, rotation and scale is applied (CTRL+A in 'Object Mode')
  • there are no ngons, non manifold elements, interior faces (you can check it very fast using a 'Mesh Lint' addon)
  • the 'Mirror Modifier is applied
$\endgroup$
  • $\begingroup$ Thankyou for answering! I have already done that though, and that doesn't work :( $\endgroup$ – user8258 Nov 30 '14 at 13:55
  • $\begingroup$ Hmmm...That's strange. You may post your .blend file via pasteall.org if you like, so we can see what's the problem and find a solution. $\endgroup$ – Paul Gonet Nov 30 '14 at 14:22
  • $\begingroup$ pasteall.org/blend/33133 $\endgroup$ – user8258 Nov 30 '14 at 17:10
  • $\begingroup$ (Trying to add a tail and some light "beard") $\endgroup$ – user8258 Nov 30 '14 at 17:29
  • 2
    $\begingroup$ I wouldn't apply the modifiers, just make sure the use modifier stack checkbox in the particle settings is checked and you should be able to put the particle systems last in the mod stack. See hair particle system not rendering properly on plane. $\endgroup$ – PGmath Dec 1 '14 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy