1
$\begingroup$

When I apply the "Solidify" modifier to my object, this one window I have acts differently then all of the others. They all look okay, but this one gets messed up by the modifier.

Here are 2 angles of the messed up part of the mesh with the solidify modifier:

Broken Mesh Broken Mesh 2nd angle

Here is the mesh without the solidify modifier:

working mesh

And here are my Solidify Modifier settings:

Solidify Modifier Settings

I got the window pains by extruding the edges out. I have already tried removing overlapping vertices and the scale is applied. Can anyone help me?

$\endgroup$
2
  • 3
    $\begingroup$ I think your normals aren't facing in the same direction. $\endgroup$
    – Ron Jensen
    Sep 7, 2020 at 1:01
  • $\begingroup$ Thanks! this worked. $\endgroup$
    – UberRix
    Sep 7, 2020 at 1:32

1 Answer 1

2
$\begingroup$

You are trying to solidify a fairly complex shape that requires you to change the Mode from Simple to Complex in the modifier's panel.

Cheers!

$\endgroup$
3
  • $\begingroup$ Thank you so much. After I change it to Complex, are there any settings I need to mess with? $\endgroup$
    – UberRix
    Sep 7, 2020 at 16:54
  • $\begingroup$ You are welcome. For your kind of shape I suggest "Thickness Mode = Even", the rest I think you can safely keep as it is. Cheers! $\endgroup$ Sep 7, 2020 at 17:03
  • $\begingroup$ Also offset to zero, probably. $\endgroup$
    – lemon
    Sep 8, 2020 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.