3
$\begingroup$

I noticed there's a weird second shadow in a plane with screen space refraction in Eevee. How to remove that weird duplicated shadow?

Weird duplicate shadow in Eevee: enter image description here

Correct result in Cycles: enter image description here

In Blender: enter image description here

Blender file here

Using Blender 2.83.4

Edited: Although setting Refraction Depth to small value such as 0.1m works removing the unwanted "shadow", but it also removes the refraction effect. To get refraction effect, the value has to be more than 1m to see noticeable effect. Putting another object on top of the plane with refraction along 1m value, the "shadow" is back.

enter image description here

New edited Blender file here

$\endgroup$
3
$\begingroup$

You have set Refraction Depth to zero.
It is not clear to me if values below are correct, but you get rid of the "shadow" thing.

enter image description here


Glass Plate

Go to Properties Editor > Material > Settings > Refraction Depth and play with value.
In your case 0,1-0,4 m works. It seems to be distance from glass to Monkey.

enter image description here

Deep Water

It seems to be more complicated ... it depend if it should be glass plate or deep water. In second case probably make sense increase to 4 m, that is distance from surface to bottom.

enter image description here

In that case you have to also increase Thickness under SSR Render Properties.

enter image description here


My theory notes behind

The "weird shadow" (as you call it) is a part of bottom plane surface that is not visible from current point of view on background plane. You can see actually through the plane what is behind in that place.

You can actually confirm that by your self. Check where is the issue located on glass plane and switch to wire mode. Real monkey object is placed exactly on the same place on background plane from current point of view .

I guess by default this is some kind if refraction clipping to keep Eevee real-time.

Similar thing happens when you try set reflected floor with object howering above - in a floor is not reflected bottom part of mesh that is hidden from point of view. Like here – Screen Space Reflections in EEVEE

See also ...

Eevee Limitations
Manual - Refraction Depth

$\endgroup$
  • $\begingroup$ Did you mean u solved it using glass distortion? I'm also using Glass BSDF for the refraction floor. From the screenshot, it seems worse than my case. Could you explain further? $\endgroup$ – kkl Sep 6 '20 at 10:22
  • $\begingroup$ Sorry it wasn't clear. Edited $\endgroup$ – vklidu Sep 6 '20 at 17:00
  • $\begingroup$ Cool it works! Managed to remove the weird "shadow" by setting the refraction depth to 0.1m. @vklidu Thanks for the detailed explanation! $\endgroup$ – kkl Sep 7 '20 at 5:00
  • $\begingroup$ i noticed setting Refraction Depth < 1m removed, but it does not have refraction effect anymore. By setting > 1m, and putting the object on top of the refraction plane, the "shadow" comes back. I updated my post to include the new Blender file and screenshot $\endgroup$ – kkl Sep 7 '20 at 13:12
  • $\begingroup$ 0,1 works like thin glass plate. I don't think you can achieve something like that. See links at the end of my A. I will have to edit answer anyway ... $\endgroup$ – vklidu Sep 7 '20 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.