0
$\begingroup$

I was testing the Fluid/Smoke Simulation in 2.9, but everytime I enabled Noise and baked it the smoke would disappear. However with noise off it works fine. I did a search and the only thing I could find is a bug report from the 2.9 beta which was closed without being resolved due to inactivity. Went back to 2.82 and the noise is working fine there.

Is anyone else able to use the Noise feature?

No Blend file as its just a default cube with a domain and more or less default smoke sim settings

$\endgroup$
1
$\begingroup$

You need to check "Is Resumable" in the Cache section of the smoke domain physics properties. Then when you bake data and bake noise, the simulation should appear in your viewport.

For some background, I was having this same issue. After doing some digging, I found this answer here: https://developer.blender.org/T80372

"This was a usability issue: Baking noise in the modular cache mode is only possible when also enabling the resumable option."

I wanted to make sure I knew what I was turning on by checking that option, so I will share this from the Blender manual as well: "Use Resumable Cache: Extra data will be saved so that you can resumed baking after pausing. Since more data will be written to drive it is recommended to avoid enabling this option when baking at high resolutions."

$\endgroup$
0
$\begingroup$

There are some issues with the cachine of fluid simulation frames in Blender 2.83+ where the old frames are not re-calculated properly when the simulation details are changed. This can sometimes result in the frames being invalidated (so they are removed) but not re-calculated when the simulation is re-run. I have seen this when using 'Replay' cache mode but the same issue may also exist when baking from the cached frames.

You can force the full simulation to be reset by changing one of the 'core' settings of the simulation - such as the Resolution. This has the effect of forcing the full simulation to be reset which does not occur when changing some of the more 'minor' settings (such as Noise). You don't actually need to change the setting - just click into the Resolution property and press Enter to accept it and this is typically enough for Blender to register that the whole simulation has been invalidated and needs to be recalculated. If you have baked the simulation you should 'free' the bake, then trigger the invalidation, then re-bake the simulation.

$\endgroup$
1
  • $\begingroup$ Ah, I knew about the 'reset' thing but I didn't know it had to be one of the core settings. Following your advice I managed to get it to work for 'replay' and 'all'. Doesn't work on the Modular setting, though. $\endgroup$ – Mark C Sep 6 '20 at 9:35
0
$\begingroup$

Had the same problem. Found that you need to use the "bake noise" button. First you need to Bake the Data, then the Bake Noise button becomes active. Once I did this, my smoke reappeared again with all the glory of noise

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.