1
$\begingroup$

I'm new to Blender and unity and working on getting an animation that I made in Blender 2.8 into Unity. I'm having issues with the character's suit, which looks great in Blender but becomes weirdly transparent and reversed in Unity. The way the figure is constructed is pretty simple- the shirt and suit and pants are all one piece like a skin, so he's basically hollow.

Here is the character in Blender: picture of guy in a suit

Here's the front of the character in Unity. Ignore the white head, I can fix that: but look at the weird suit! guy with transparent suit Here is the back of the guy. It's hard to tell which way he's facing, but the direction of the head is correct, so you see the tie through the back of the suit, and not from the front.

suit looking weird

What the what? Any help will be wildly appreciated!

Edited to add: THANK YOU! The flipped normals idea makes sense, but when I flipped anything problematic and re-import it still looks the same. Am I missing something? Here is the suit in Blender... enter image description here enter image description here

$\endgroup$
  • 1
    $\begingroup$ you probably need to flip the normals, in game engines if the face is flipped you'll see it transparent $\endgroup$ – moonboots Sep 4 at 21:36
  • $\begingroup$ Thank you! Can you tell me if there's a better way to do that than what I did? I selected all the vertices on the suit in edit mode then went to mesh>normals>recalculate outside. I did that before I got this problem because it sounded right, but it was still weird. Should I have done all the front, then all the back vertices or something? $\endgroup$ – Sam Simpson Sep 4 at 21:49
1
$\begingroup$

The normals on the object are flipped.

To visualize which normals are facing in or out, enable the option in the 3d viewport overlays > Geometry > Face Orientation

enter image description here

Blue faces are pointing out, orange are pointing in.

Or you can use overlays as well to display face normals.

enter image description here

Normals are displayed as blue lines, and you can choose the length of the lines.

To flip faces, select them and press Alt+N and select flip normals, or recalculate outside.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Excellent! Thank you! I will try that tomorrow! $\endgroup$ – Sam Simpson Sep 4 at 22:34
  • $\begingroup$ is it not alt N? $\endgroup$ – moonboots Sep 5 at 5:17
  • $\begingroup$ @moonboots indeed! $\endgroup$ – susu Sep 5 at 7:13
  • $\begingroup$ Huh! That made perfect sense, and I was very hopeful, but when I flipped the problematic parts of the suit and resaved it still doesn't work. I merged a bunch of vertices and tried a bunch of times to make sure all the normals were doing what they should be but it still imports into Unity as if it's inside out. Any more ideas would be so appreciated! I'm new and I'm so happy to have help! (added images of my suit with the normals showing to the original post, so you can see what I see..) $\endgroup$ – Sam Simpson Sep 5 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.