0
$\begingroup$

I am trying to paint textures onto an object in 3D paint in 2.72b that has several textures. The first texture in the list is a color and the second is a bump.

The problem is that texture paint will only paint the first texture in the list. In edit mode I have the correct texture selected, shading is set to GLSL solid textured but Blender is ignoring whatever is selected in edit and only using the first texture.

tex1 - color
tex2 - bump
If I go into edit mode and select the color texture as active and go back to object paint it paints the color map.
If I go into edit mode and select the bump texture as active and go back to object paint it paint the color map.

Is there a setting that I've missed or should I head over to the bug tracker?

$\endgroup$
  • $\begingroup$ Which renderer do you have set? $\endgroup$ – Ray Mairlot Nov 29 '14 at 16:33
  • $\begingroup$ I'm using Blender Internal so that I can use GLSL for live bump map painting. $\endgroup$ – Hellfireboy Nov 29 '14 at 16:36
1
$\begingroup$

It appears to be a bug in 2.72 versions. I created a simple scene of a cube with a bump and a color texture in 2.72b and then downloaded copies of 2.69, 2.70a, 2.71, 2.72, 2.72a, and a standalone zip of 2.72b. Everything works as it should up to 2.71. The problem showed up in 2.72 so I didn't even bother with the a and b versions. I've put in a ticket on the bug tracker at https://developer.blender.org/T42769 so if anyone is having the same issue they can track the issue there.

$\endgroup$
1
$\begingroup$

The bug report that I put in has been resolved and the solution is... read the release notes thoroughly.

In Blender 2.72 there is a new tab in the paint mode called 'Slots' and it replaces the old method of selecting images in the UV viewer to make them active as well as nearly all of the functions of the Layer Management plugin.

Even if you don't have a material assigned to the object it will create one when you go into paint mode with a default texture for diffuse color. If you want to create a new texture such as specular, normal, alpha, etc. there is a drop-down to select the texture that you want to add and it will open the image creation dialog to make the image. It will then create the image with the appropriate settings.

To change the image that you are painting to just select the one that you want to work on from the list. You can also delete or hide textures from this list without having to go back to the texture list in the material. Thanks to Anthony Riakiotakis(psy-fi) for clearing that up for me.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.