2
$\begingroup$

The below given image is rendered with 1000 samples with appropriate light settings but the final rendered image is coming as smudged. Is there any solution to fix this?

Wine Glasses

EDIT : please find the link for .blend file below.

https://drive.google.com/file/d/0B5pwuQ_y8BGXaURWMWxOLUVlWWc/view?usp=sharing

$\endgroup$
  • $\begingroup$ Are your normals consistent? Do they all point to the same side of the surface? If not they will cause problems for the lighting calculation. To make your normals consistent go into edit mode, select everything and press [Ctrl]+[N]. $\endgroup$ – maddin45 Nov 29 '14 at 15:20
  • $\begingroup$ the blender-internal tag is for the blender internal rendering engine, not just blender in general. $\endgroup$ – PGmath Nov 29 '14 at 15:22
  • 2
    $\begingroup$ It would be helpful if you could upload your .blend file to a site like pasteall.org so we could take a look at it and see what is wrong. $\endgroup$ – PGmath Nov 29 '14 at 16:41
  • $\begingroup$ I uploaded the blend file, please check and sorry for the wrong tag line. $\endgroup$ – Alok Vishwakarma Nov 30 '14 at 4:43
  • $\begingroup$ @maddin45 No, the light setting is all correct. $\endgroup$ – Alok Vishwakarma Nov 30 '14 at 4:46
3
$\begingroup$

When dealing with glass you need the object to have some thickness. To illustrate the issue with two identical glasses:

enter image description here

The glass on the right has only a subsurf modifier, you can clearly see a lot of artifacts as white and black bands. The one on the left has a Solidify modifier before the subsurf. The glass looks much cleaner and realistic, and you don't need that many samples (This image was rendered with only 100 samples)

enter image description here

$\endgroup$
3
$\begingroup$

There are two problems with your mesh that I can see.

While in Edit Mode, you can select a face along the rim and move it to see that there is another layer in the same spot.

enter image description here

To clean up the overlapping faces you can use the Remove Doubles tool since all the vertices are in exactly the same places. It's available in the Toolshelf and can also be accessed by pressing w to access the Specials menu.

enter image description here

Now you may see an big mess because some of the faces are inside out and I have backface culling disabled so I can spot errors like this.

enter image description here

Ctrl+n will make the normals consistent.

enter image description here

After recalculating the normals, the inside face of the glass is backwards. By hovering over one of it's vertices and pressing l you can select the entire piece at once as shown below. Next you can press Ctrl+f to access the Faces menu and choose Flip Normals. The previous image shows where the tool is located in the Toolshelf.

enter image description here

Now for the second problem that you mesh has. For the Glass Shader to function correctly, the mesh should be completely enclosed. As it is now, there is no rim and this should be filled in. You can do this easily by holding Alt and clicking the Edge. Next press and hold Alt + Shift then Click the second Edge to add to the selection. Now you can press Space and type in find the Bridge Edge Loops tool.

enter image description here

The black inky blobs you see are shadows and I have no idea how to clean that up without disabling shadows for the entire scene. If you figure that out, feel free to share your results. :)

enter image description here

I also added an Environment texture and a couple extra lights since Glass tends to look better when there are surroundings to reflect and refract. Here are the render settings I used except that I increased the Samples to 1024.

enter image description here

Also, the ground plane is actually two ground planes that are overlapping. The next image shows one of the two ground planes moved down to show it's there. It's something that you should always watch out for because it will cause rendering artifacts if geometry overlaps like this. With Object Mode overlaps this is easy to fix, just delete it.

enter image description here

$\endgroup$
0
$\begingroup$

You have a lot of duplicated vertices!(762 per glass, to be precise) so what you see as smudges is a bad case of Z fighting. go to edit mode, select all vertices and do "remove doubles"

enter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.