2
$\begingroup$

okay, i've run through this process a few times in 2.79, and i have gotten it working. however, now i need to create the rigify metarig in 2.83.4, and i'm running into an error i don't understand.

other instances of this problem here seem to indicate that bones rigify needs were deleted. but i haven't deleted any rigify bones. i AM starting with a plain single bone and only adding limb "samples." again, the same way i have done multiple times in 2.79.

https://prnt.sc/uaygcs

i tried using the "standard" names for Paw limbs on the bones, as listed in the blender/rigify manual, though i didn't have to do that in the old version. the 2.8 rigify also threw an error when i had an extra bone on the end of the hind limb (previously, it had just ignored that bone, but at least created a DEF and ORG bone for it). i removed that, but still the indexing error.

it creates the root, and the other basic super copy bones, then croaks on the limbs :/ it wont do the hind by itself, nor the fore by itself.

i manually separated the tail of the collar/hiplink bones from the chain, even though they are parented but not 'connected,' which rigify should recognize.

okay, i deleted all the bones except the root, added an UNTOUCHED paw sample, hit generate, and no. same error.

WHAT DOES THIS ERROR MEAN? it sounds like it's not finding any bones in a chain?

Duplicate rig: 0.004
Make list of org bones: 0.001
Instantiate rigs: 0.000
Initialize rigs: 0.000
Prepare bones: 0.001
Rigify: failed to generate rig.
Traceback (most recent call last):
  File "E:\GFX\blender\blender-2.83.4-windows64\2.83\scripts\addons\rigify\ui.py", line 765, in execute
    generate.generate_rig(context, context.object)
  File "E:\GFX\blender\blender-2.83.4-windows64\2.83\scripts\addons\rigify\generate.py", line 523, in generate_rig
    raise e
  File "E:\GFX\blender\blender-2.83.4-windows64\2.83\scripts\addons\rigify\generate.py", line 511, in generate_rig
    Generator(context, metarig).generate()
  File "E:\GFX\blender\blender-2.83.4-windows64\2.83\scripts\addons\rigify\generate.py", line 409, in generate
    self.__create_root_bone()
  File "E:\GFX\blender\blender-2.83.4-windows64\2.83\scripts\addons\rigify\generate.py", line 218, in __create_root_bone
    spread = get_xy_spread(metarig.data.bones) or metarig.data.bones[0].length
IndexError: bpy_prop_collection[index]: index 0 out of range, size 0
Error: Generation has thrown an exception: bpy_prop_collection[index]: index 0 out of range, size 0

file: https://drive.google.com/file/d/1evuiAaeHtfNl3eyheyHXQeKxUrZDJO5G/view?usp=sharing

$\endgroup$
4
  • $\begingroup$ I just tested it in 2.9, 2.83 and 2.79. All is working fine. The rig is generated without any error message. $\endgroup$
    – LeoNas
    Sep 3, 2020 at 16:37
  • $\begingroup$ so... 2.83.4 sub-version might be the problem? or i selected something wrong? or it was the wrong day, and the moon was in the wrong house!?!? i'll try again, thanks for looking! :) $\endgroup$
    – blr
    Sep 22, 2020 at 15:44
  • $\begingroup$ Same error here, even using the provided default meta-rig or human base rig I get the same error. $\endgroup$
    – Ray
    Feb 2, 2021 at 0:46
  • $\begingroup$ i'm back. rigify is STILL broken. i deactivated EVERY SINGLE ADDON in blender 3.0.0 except Rigify, saved preferences, restarted blender, started a NEW file, added the rigify default human (or any), pressed the 'generate rig' button... and index 0 error: prnt.sc/kYnIeZ5gqTsT same console traceback: prnt.sc/hA4rQ3RIta1s $\endgroup$
    – blr
    Mar 3, 2022 at 14:42

1 Answer 1

0
$\begingroup$

In order for the Rigify Generate button to work, the option in Preferences > Editing > Objects > Duplicate Data > Armature must be checked.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .