10
$\begingroup$

I am looking to reduce the size of the shadow being cast on the mesh in the background..

enter image description here

I have only one light which is a sun lamp with ray shadow on, the mesh i have receive, receive transparent and cast buffer checked and no matter how near or far i put the light I cannot get the size of the shadow to change. Can anybody help. cheers.

$\endgroup$
7
$\begingroup$

You have something like this (Blender Internal) enter image description here

Sunlight lamp only lets you change the angle of the light-source and not the distance of the light to the scene objects. Test this by moving the sunlight closer or further away from the objects, compared to rotating the sunlight. If you want smaller shadows, don't use a sun lamp on its own. When you only have one light-source like a sunlight on default settings, you will get sharp shadows.

You can fake ambient light by adding Ambient Occlusion or Environmental Lighting, or add a few weak lights to give you more control.

adding Ambient Occlusion would give you this: enter image description here

or adding Environmental Lighting for this: enter image description here

You could also mess with the shadow settings of the sunlight lamp: (softsize & samples & shadow colour). But on its own that still doesn't produce a nicely illuminated image.

enter image description here

The trick really is to add more lights, but make them weak so as not to saturate the scene. If you are serious about lighting I recommend you read this classic post by Ben Simonds about lighting techniques.

$\endgroup$
3
$\begingroup$

You can only change the angle and softness of a Sun lamp's shadow.

Sun Lamp

A Sun lamp provides light of constant intensity emitted in a single direction. A Sun lamp can be very handy for a uniform clear daylight open-space illumination. In the 3D view, the Sun light is represented by an encircled black dot with rays emitting from it, plus a dashed line indicating the direction of the light.

This direction can be changed by rotating the Sun lamp, like any other object, but because the light is emitted in a constant direction, the location of a Sun lamp does not affect the rendered result (unless you use the “sky & atmosphere” option).

For more control of the shadow you'll need to use another of the available lamp types.

$\endgroup$
0
$\begingroup$

Another trick is to remove shadows from the main objects and create duplicates to cast the shadow.

First under shadows of the material tab check on "receive transparent" on everything that's in shade and turn off cast shadows for the object(s). Then duplicate the mesh with separate materials from the original with "cast" and "cast only" on. You may want to make the duplicate any amount smaller, I got a visual glitch with them overlapping. Turn on transparency and adjust alpha or Fresnel, or adjust the size, location, or whatever to change how the shadow is sent.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.