0
$\begingroup$

ShiftS + Pie Menu is working as expected. In Object Mode the 3D Cursor jumps to an object's Origin. In Edit Mode it jumps to the selected geometry.

The custom keyboard shortcut I assigned however, is only working in Edit Mode. In Object Mode it does not jump to the selected objects. What might cause this?

I've assigned the shortcut in the 3D View > 3D View (Global) section. This made it work... for Edit Mode only.

I've also tried placing it in:

  • Object Mode (Global)
  • 3D View (Generic)
  • Object Non-modal

No luck getting the shortcut to work in Object Mode. It's strange because the Console shows the same command I've typed (beginning after bpy.ops.): view3d.snap_cursor_to_selected

(I'm using version 2.9 now, and had this shortcut working in 2.79)

$\endgroup$
0
0
$\begingroup$

An existing shortcut called Select Hierarchy at the Object Mode (Global) level was taking precedence over any key bindings I was setting at the 3D View (Global) level (and other levels/sections I had tried).

I resolved this by reassigning the Select Hierarchy shortcuts to other modifier keys:

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.