1
$\begingroup$

I am using Blender 2.83 as a part of my Masters project. I have obtained 3D models of various fishes (.obj files), and I import them using

File > Import > Wavefront (.obj)

The models loads without errors, but the textures are "corrupted". I would appreciate any help and/or pointers on how to fix this. You can see images below. The "dark spots" are transparent spots

"Corrupted" textures

Some (maybe all) of the models are obtained from sketchfab, which have 3D previews where the textures look correct. The fish "groups" are the models viewed from left and right.

Beneath you can see a closer look of a model as well as the UV-editor view in case that is relevant.

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Hello, maybe pack your images and share one of your fishes so that we can take a look: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Sep 3 at 10:09
  • $\begingroup$ Hello :). If this only happens in Eevee, you need to change the material blend mode (perhaps to opaque). $\endgroup$ – Jachym Michal Sep 3 at 11:06
  • $\begingroup$ @JachymMichal Thank you very very much, that fixed it! If you post as an answer I can check your answer as correct :) $\endgroup$ – Naphat Amundsen Sep 3 at 11:24
0
$\begingroup$

This is cause by your material's blend mode.
You have 2 options:

  1. In Material settings uncheck Show Backface
  2. Change Blend mode to Opaque (this will fully disable transparency)

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.