5
$\begingroup$

Not sure what I did to mess it up but now when I press E to extrude it is set to the z axis. It has always been axis free when initially pressing E and you had to press Z to lock it to that axis. Now I have to press Z to unlock it first, I would prefer not to have to do that every time I extrude.

$\endgroup$
6
$\begingroup$

Pressing E performs "Extrude and Move on Normals", for a basic cube extruding the top face will appear to be extruding on the global z-axis while extruding a side face will match the x or y axis.

I don't know which version you think this performed different, not certain with 2.5x but I have 2.62 through to 2.72 available here and they all work that way.

There is a chance that you had a bad habit before. Pressing E will extrude and start moving the new geometry, right-clicking will cancel the move, but you can right-click again on the selected face/s and start moving the new extrusion. Maybe you had been cancelling and picking up the geometry without realizing it.

You can change this behaviour if you wish by opening the preferences and adjusting the method used. While in the Input settings search for extrude and adjust the one saying "Extrude and Move on Normals" under Mesh. When you expand it you will see a text field with view3d.edit_mesh_extrude_move_normal - change that to mesh.extrude_region_move. This should give the behaviour you are looking for.

enter image description here

You can then Save User Settings so that it is set that way each time you use blender.

$\endgroup$
2
$\begingroup$

Middle clicking after hitting E wil unsnap something from an axis. this is the same for translating, scaling, or rotating an object. Middle click again and your target will snap back to the nearest axis. This is much faster than hitting the keys for the respective axis, and if used right, can make modelling faster.

Why yours wasn't snapped in the first place, I don't know. Mine has always from default.

$\endgroup$
1
$\begingroup$

If you want to get rid of the lock while extruding a face, simply get rid of the "face" that you are extruding.

If you have vertices selected as below and press "E" there will be no lock.

deleted_face

$\endgroup$
0
$\begingroup$

I had a similar problem, and it turned out being that the object's scale was set to 0.0 in one of the dimensions - effectively making it completely flat. Increasing the scale for that dimension fixed it for me.

$\endgroup$
0
$\begingroup$

If you use the extrude tool a lot it will lock onto an axis, to fix this press z until the axis lock clears.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.