10
$\begingroup$

I thought that I was able to use my mouse to navigate in the viewport before. I can only seem to rotate the project view via the numpad keys. I have tried to Google for my problem but can not seem to find any answers.

$\endgroup$
5
  • $\begingroup$ What buttons are you trying? middle click is used to orbit, left for setting the 3D cursor, and right is for selecting. $\endgroup$
    – ruckus
    Nov 28, 2014 at 23:43
  • $\begingroup$ Also, shift+middle click to pan $\endgroup$
    – ajwood
    Nov 28, 2014 at 23:51
  • 1
    $\begingroup$ Middle button does nothing but zoom when i use scroll wheel.. i have pressed shift+middle and it does nothing.. $\endgroup$
    – Jen
    Nov 29, 2014 at 0:05
  • $\begingroup$ Go to file>user preferences>input>3D view>3D view (global) and make sure all the settings are correct. The orbit setting should say "middle mouse" if this is right, and you still can't get anywhere with it, than your mouse may be busted, and that's out of my scope :) $\endgroup$
    – ruckus
    Dec 1, 2014 at 23:17
  • $\begingroup$ I had the same problem, first sr for my bad english but the only thing what u need is to unplug ur mouse and w3 3 Sec. and then plug in back without closing the blender file. And its gona work again, i think its a bug $\endgroup$ Jan 12, 2023 at 10:51

4 Answers 4

19
$\begingroup$

You can try one of the following

  • View > View selected or . on Numpad
  • If that doesn't work try Shift + C

It seem that with some blend files "zooming to much" locks the 3D view and you can only rotate the view, not pan or zoom in or out, with other .blend files it is OK... don't know the real source or how to fix the file, anyway if you still want "free zoom, pan and rotate", you can copy the objects that you need to a new .blend.

$\endgroup$
1
  • $\begingroup$ Shift-C worked, thank you $\endgroup$
    – Mastro
    Mar 19 at 13:22
1
$\begingroup$

With Corsair Scimitar pro I had to modify the mouse settings in the ICUE dashboard:

  1. Add an Action
  2. In the drop down menu for action and remap I clicked "Mouse Button" under the Remap column
  3. Mapped it to the "Middle Click" in the Devices area above that.

This seemed to fix the problem.

$\endgroup$
0
$\begingroup$

If you're using Razer products for peripherals, you will need to open up Razer Synapse and change your middle mouse button from left click to scroll click, save your profile configuration and try this again in the 3d viewing window. Other Manufacturers that do not use the windows default drivers but rather their own software may have a similar problem with their configuration/keybind. Hope this helps, took me 30 minutes to think of.

$\endgroup$
0
$\begingroup$

I figured out another reason, as for panning left, right, up, and down. Check the clip start under view (shortcut N on keyboard). If that is set too low it might cause an issue for you to pan.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .