0
$\begingroup$

A strange problem with my mesh I have tried flipping normal's and Cleanup by distance but still have strange faces that don't smooth Any ideas? Its very visible with thickness mod added...

Physically there is nothing wrong with the mesh, quad based, clean and no overlapping faces or bad polls

I tried delete loose, flipping normals, set from faces (which made it worse) A bit stick since I want to sculpt on it but with misbehaving normals that wont be possible...

I'm not sure what the blue lines mean but they seem related... Clear sharp doesn't work though

[1]: https://i.stack.imgur.com/Oyaon.png

enter image description here

$\endgroup$

5 Answers 5

2
$\begingroup$

Try making sure that there are not doubling vertexes,or split vertexes, you can use the merge by distance in the mesh/clean up menu.

$\endgroup$
1
  • $\begingroup$ Thanks I already tried that, unfortunately it doesn't change anything. $\endgroup$
    – StackBuddy
    Sep 2, 2020 at 16:50
1
$\begingroup$

How about run the remesher on it?

$\endgroup$
1
$\begingroup$

I found the problem, thanks for the Remesh suggestion, I noticed there was a panel for normal's above to switched off autosmooth - it seems to fix the problem, which must be a display problem rather than a problem with the mesh

Thanks so much for your time and suggestions! although they didn't work they did help narrow down the source of the problem. Auto-smooth I'm staring at you XD

enter image description here

$\endgroup$
3
  • $\begingroup$ Can u explain why autosmooth caused that weird shading? That's important while answering because it will be helpful for others with the same issue in the future. $\endgroup$
    – Nxdhin2005
    Sep 2, 2020 at 17:37
  • $\begingroup$ I cant explain technically why, as I don't understand the inner workings of auto smooth on the mesh normals and viewport shading and why It was behaving in that way on a clean mesh, but I can say the solution was to turn it off - which resulted in a clean shaded mesh as expected. Physically there was nothing wrong with the mesh, quad based, clean and no overlapping faces or bad polls.... $\endgroup$
    – StackBuddy
    Sep 3, 2020 at 18:40
  • 1
    $\begingroup$ Found due to "automod" updating; I'll give an answer that explains why autosmooth does what it does. $\endgroup$
    – Nathan
    Nov 27, 2021 at 6:00
1
$\begingroup$

It's not possible to say exactly why from your question, because it could be due to ripped edges. However, based on the solution you posted, I can confidently say it is because of autosmooth settings (which you realized.) I can also explain why autosmooth did what it did.

Basically, autosmooth is poorly named. It does not smooth anything. It should be named "autosharp" because what it does is automatically sharpen edges of a smooth-shaded mesh. (It will not do anything to a flat shaded mesh.)

Autosmooth is a technique to automatically mark edges as sharp or smooth on the basis of the angle between the two faces joined by that edge. You'll notice on autosmooth settings that, in the absence of custom normals, there is a number associated it with it, a number that you can change, that defaults to 30 degrees. What that means is that autosmooth is automatically marking as sharp any edges that represent a 30 degree angle or greater. If you change that number to 90, it will mark all edges sharp that represent a 90 degree angle between faces. Like all sharp edges, these edges create split per-corner vertex normals. It is very similar to ripping those edges, perhaps with an edge split modifier: the faces on the other side of the sharp edge will be ignored by the corner-vertices on this side of the sharp edge.

Why would you want to use autosmooth? Let's say you're making a tank. It has sharp edges, but it also has smooth edges-- the turret, the body. By enabling autosmooth and tuning the angle of the edges that get sharpened, you can probably not worry too much about tediously marking this edge sharp, but not that edge. You can just have it calculated on the basis of face angles.

Note that autosmooth is also used on meshes that have custom normals. Custom normals are per-corner in Blender. All vertices have custom normals or no vertices have custom normals, although a particular corner might have custom normals that agree with its default vertex normals. When you have custom normals, autosmooth tells Blender to use your custom normals; otherwise they are ignored. In this case, enabling autosmooth does not sharpen any edges, and you'll see that the angle field is grayed out and uneditable; it is ignored. If you need to disable custom normals in favor of autosmooth's auto-sharpening, you need to discard all of your custom normals (in properties/object data/geometry.)

$\endgroup$
0
$\begingroup$

The blue lines means that it is the edges is marked as sharp. You just need to select the edges or the whole mesh and select Smooth Edges in Mesh > Shading.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.