0
$\begingroup$

In 2.79 I have the following keyboard shortcuts assigned for Edit Mode:

  • Vertex Select: Cmd1
  • Edge Select: Cmd2
  • Face Select: Cmd3

Note: I'm using "Emulate Numpad", so I register a shortcut as Numpad 1 instead of 1, for example.

Here's what the key binding that controls that in 2.79 looks like:

Blender 2.79 Vertex Select Keyboard Shortcut

And here's what I tried in 2.90 that isn't working:

Blender 2.9 key binding not working

I believe it has to do with the RNA field not existing in 2.8+ but I'm not sure how RNA works. What would be the way to do this in newer versions of Blender?

$\endgroup$
2
$\begingroup$

There are two problems that need to be solved:

  1. The shortcut you're attempting to assign is already in use for the viewport navigation. You may want to change these so you're still able to use them with a different key binding.
  2. The identifier for the operator is not correct, but creating a new shortcut isn't necessary since the mode selection already exists in the default keymap. You only need to adjust the key binding from the regular 1, 2 and 3 keys to the numpad ones.

In order to solve problem 1):

  1. Open the keymap preferences
  2. Switch the filter method to Key-Bindings.
  3. Search for "Numpad"
  4. Scroll down to find the 3D View section and adjust the shortcuts that use Ctrl + Numpad 1, Ctrl + Numpad 2, Ctrl +Numpad 3. (If on a Mac there will also be Cmd + Numpad 1, Cmd + Numpad 2, Cmd +Numpad 3, in which case either the Ctrl or Cmd set can be deactivated, freeing up some shortcuts.)

View Axis keyboard shortcuts when viewed on a Mac

In order to solve problem 2):

  1. Open the keymap preferences
  2. Switch the filter method to Name
  3. Search for "Select Mode", the identifier for the operator is mesh.select_mode.
  4. Adjust the key binding to your liking.

Reassigning the Mesh Select Mode Shortcuts

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you so much! You've helped me migrate from 2.79 to 2.9. I'm finally reimplementing all of my shortcut customizations, and this was an important one. 2.9 is feeling a lot more comfortable now! (BTW, Ctrl on macOS also triggers the back views, so I just left those as they were, and remapped the Cmd versions which were redundant anyway - perfect!) $\endgroup$ – Mentalist Sep 3 at 11:01
  • $\begingroup$ I added some screen shots to your answer, along with additional details for Mac users. I hope you don't mind. $\endgroup$ – Mentalist Sep 3 at 11:13
  • 1
    $\begingroup$ @Mentalist Not at all, I think the screenshots and Mac specific information are a nice addition. $\endgroup$ – Robert Gützkow Sep 3 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.