1
$\begingroup$

I am trying to rig a character using Rigify but I run into this error when I hit "generate rig".

The error says "Generation has thrown an exception: 'NoneType' object has no attribute 'bones'.

I have modified the rig in edit mode, however I have done so before with rigify and never ran into this problem.

enter image description here

Here is a link to the file: https://drive.google.com/file/d/1dG_hfjoPC-0QzFdUP0qCrWlxB2T1Le3F/view?usp=sharing

Thank you in advance!

$\endgroup$
  • $\begingroup$ Your file 1.5GB :) I'll take a look but you could delete the character and upload it again. We only need the meta rig to check the problem. $\endgroup$ – CGDive Sep 3 at 0:33
1
$\begingroup$

The problem is that for one reason or another the "Rig Type" is missing from your spine. Sometimes that happens due to a bug in Blender itself.

The fix is easy. In your MetaRig select the bone I have highlighted in the image. Make sure you're in Pose Mode! Go to Bone tab and under Rigify Type choose spines.basic_spine Make sure your generated rig is visible and press Generate Rig. That should fix the non type error.

enter image description here

If you're interested, the error itself comes from the head/neck, because it has the "connect chain" option ON. This requires it to be snapped to another chain of bones. But since the Rig Type was missing, Rigify just ignores the Spine bone chain. And that produces the error.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ oh my god thank you so much! this has been bothering me for DAYS! $\endgroup$ – rmorg912 Sep 4 at 7:30
  • $\begingroup$ Nice, glad it was resolved! $\endgroup$ – CGDive Sep 6 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.