I'm trying to make Text in blender. I downloaded for example Work Sans font from Google fonts. In text properties I choosed downloaded .ttf files, but for some reason font is broken.

enter image description here

I'm using this font in Inkscape or Gimp without problems. Why it is so weird in Blender?

I also tries to convert it in multiple tools from TTF to TTF without results, or TTF to WOFF but this format is not supported. What else can I try?

  • 1
    $\begingroup$ Hello :). I'm afraid Blender's Text tool has some unfortunate limitations. I encountered this with some google fonts which work just fine elsewhere :). $\endgroup$ Commented Sep 2, 2020 at 14:09
  • $\begingroup$ @JachymMichal Blender is such powerful tool with huge amount of great functions but such simple thing like text does not work? It's just crazy. It's like sport car where windshield wipers are broken and unable to fix. $\endgroup$
    – chojnicki
    Commented Sep 2, 2020 at 14:40
  • 1
    $\begingroup$ I work with typography every day, so I feel your pain :).If you need to get text into blender, you can export it as. svg from illustrator. Hopefully Blender will get better at handling text soon. $\endgroup$ Commented Sep 2, 2020 at 14:44
  • 1
    $\begingroup$ @JachymMichal problem fixed :) $\endgroup$
    – chojnicki
    Commented Sep 2, 2020 at 14:49

2 Answers 2


Fixed :)

For every one else with this problem:

Previous attempts to use different format was a good idea, but WOFF was not supported, so I found out that blender supports also OTF. I downloaded pack from Fontsquirrel (otf by default) instead Gooogle fonts and it works :) Converting TTF to OTF would probably work too, but I did not tried this.

So short answer - use OTF instead TTF because TTF in Blender is buggy.

Edit: I found out that font format is not the case. Blender cannot handle glyphs in fonts with overlapping shapes (so for ex. "X" should be single mesh and not two crossed boxes one on top of another one). In my case same font from other source was fixed.

But we can fix this manually (merge shapes of glyph) in any font editor like glyphrstudio.com (online) or FontForge (desktop).

  • 2
    $\begingroup$ Glad you fixed it. If something is "buggy", please consider to file a bug report (Help > Report a Bug), thanks. $\endgroup$
    – brockmann
    Commented Sep 2, 2020 at 14:57
  • $\begingroup$ You can also convert the line without mesh cap into segments and weld them manually before filling in the faces and extrude it ... if it's faster. But yeah OTF is the way to go. $\endgroup$
    – hawkenfox
    Commented Sep 2, 2020 at 19:10
  • 1
    $\begingroup$ Hey :). Thanks for the update, much appreciated. $\endgroup$ Commented Oct 10, 2020 at 20:19

These are the steps to fix font intersection issues in Font Forge:

  1. Download Font Forge (free and open source)
  2. Open the font file you want to use in Blender
  3. Select all with Edit > Select > Select All
  4. Remove overlap with Element > Overlap > Remove Overlap
  5. Generate font from File > Generate Fonts…

Screenshot of a TTF font opened Font Forge with the Edit, Select, Select All dropdown menu path highlighted

Second screenshot of Font Forge with the Element, Overlap, Remove Overlap dropdown menu path highlighted

Third screenshot of Font Forge with the File, Generate Fonts… dropdown menu path highlighted

I used the default TTF options when generating fonts. It takes all of 10 seconds to open a font file, process, and generate the patched file. Even easier if you macro the keyboard shortcuts (in MacOS that's Command + A, Command + ⇧ Shift + o, Command + ⇧ Shift + G).

In my usage, this worked perfectly to fix the static font files from a variable font design hosted by Google Fonts. Seems like conversions are pretty basic, and the static alternatives still retain all of the overlapping and intersecting needed for variable usage even when no longer variable. But following the above stops, the files now work without issues in Blender.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .