1
$\begingroup$

I'm trying to use models from 3d Warehouse inside my Blender scene. So I'm downloading them in Collada (.dae) format instead of Sketchup formats since Blender can import dae.

Problem is that they are included with weird black wireframe, even that I have wireframes hidden. I cannot find way to hide it. In render they look ok, just not in viewport.

enter image description here

$\endgroup$
5
  • $\begingroup$ Object Properties > Viewport display > Wireframe $\endgroup$ – Gorgious Aug 31 '20 at 13:50
  • $\begingroup$ @Gorgious It's disabled bad lines are still visible. Also it does not look like Blender's wireframe, because lines are cropped and not straight lines like in normal wireframe. $\endgroup$ – chojnicki Aug 31 '20 at 13:53
  • $\begingroup$ Have you disabled it for every one of your objects ? $\endgroup$ – Gorgious Aug 31 '20 at 13:56
  • $\begingroup$ @Gorgious it's disabled by default. Enabling this option is adding another wireframe on top of it. $\endgroup$ – chojnicki Aug 31 '20 at 13:57
  • $\begingroup$ It is due to Sketchup... bad geometry and hard to clean up. But dae export from Sketchup standalone solves the issue. A sketchup importer can be found on the internet but it does not work well with materials. $\endgroup$ – lemon Aug 31 '20 at 14:06
0
$\begingroup$

I had same look with my model when imported .dae In my case it was textured mesh+ wireframe. So just go to edit mode, and in material properties click on your material and press select (do this with all materials). After that you should have selected all mesh without wireframe (you can press ctrl+i to invert selection to wireframe and delete it)

Hope this will help you.

$\endgroup$
1
  • $\begingroup$ I do not need this anymore and I cannot check it, but thanks for answer :) My solution at the time was editing .dae in text editor to delete all wireframes whatever they were named in source. I also typed regex for faster search & replace. $\endgroup$ – chojnicki Jan 7 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.