1
$\begingroup$

I am working on a set of brushes that use an Anchored stroke, but the texture used for my brush is not completely showing when I use the brush. If I increase the hardness it helps a little bit, but Blender is still clipping the edges.

Here's a quick capture that shows what I'm talking about:

enter image description here

Notice that the edges of the brush stroke are faded out, and you can't completely see the whole texture.

Here's the texture/alpha I'm using:

Alpha

Here's the brush with different levels of hardness:

Medium High

As you can see, even with a high hardness value, the alpha is still being clipped.

Is there a setting or toggle that I'm missing here? Can someone possibly tell me how to fix my alpha so it works correctly?

Thanks so much.

$\endgroup$
1
  • $\begingroup$ not sure but is that a transparant .png or is it black white. i can imagine black sets to 0 height while transparant doesnt alter... but i've never used it so its a wild guess. $\endgroup$
    – Peter
    Sep 3 '20 at 13:30
4
+50
$\begingroup$

It looks like this is because of two things.

First is the default falloff settings. Just below the texture heading is a falloff heading, shown below:

enter image description here

The default is a smooth falloff, which has a strength of 0 at the edges, even at full hardness I believe. The solution is to switch to a constant falloff. Just be aware that this can cause hard edges on the brush if the texture suddenly gets cutoff...

Which is the second reason. The sculpt brush is round, and your texture is square, meaning that the "corners" of the square will be clipped. The solution is to increase the texture scaling values under the Texture heading. This will scale down the texture a bit so that the square image fits into the round brush.

An alternative is to make the texture itself have a larger black border, so if scaling doesn't work for some reason, that would be the next best thing I think.

$\endgroup$
1
  • $\begingroup$ Thanks so much for the detailed explanation. Will award the bounty once SX lets me. $\endgroup$
    – Jay
    Sep 3 '20 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.