0
$\begingroup$

When I use CPU everything works fine, but when I switch to GPU all materials using Principled BSDF or Glass BSDF shaders go completely black in the viewport rendered view; all other shaders seem to work fine. I am using Cycles in blender 2.83 and my graphics card is a GeForce RTX 2060, which I just updated.

$\endgroup$
2
  • $\begingroup$ No info about render engines and shading modes the issue appears in. Try to set materials blend mode to Alpha Blend instead of Opaque in the material settings. Render engine should be set to Eevee for this option to appear, but those settings should also affect Material Preview shading mode back in Cycles. Also if you use Cycles try to increase Transparency samples in Render Settings -> Light Paths. $\endgroup$ Aug 30 '20 at 6:47
  • $\begingroup$ @AndreySokolov my apologies. The problem only appears in Cycles; works fine in Eevee. Increasing the transparency samples didn't help, and the Material Preview shading mode gives the best results with the Opaque blend mode with both engines. $\endgroup$ Aug 30 '20 at 11:03
1
$\begingroup$

I don't know if you solved this, but I had a similar issue until I realised that I had Transmission Bounces set to zero (not Transparency bounces as mentioned in your comment above) ...

enter image description here

$\endgroup$
1
  • $\begingroup$ It's been a while since I posted this, and I don't remember how I solved it. However, the exact same problem appeared just a few days ago, and a simple PC restart solved it. I'm assuming the same thing happened last time. $\endgroup$ Apr 6 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.