0
$\begingroup$

I'm trying to create an animation using SplineIK's with tracking bones into UE4 using their Send to unreal Tool.

within blender everything appears to be correct with the animation, however once uploaded to UE4 the head of my little snake friend makes a 180 during a couple points in the animation.

When saving the keyframes for the action/animation I have tried using the Insert Key frame menu>LocRotScale and VisualLocRotScale options. Both of them return the same results.

both pictures below are of the same keyframes.

The circles are the targets

The way i have the spline IK setup is I have target bones within the same armature as the weight painted bones. the Targets are Hooked to each point in the BezierCurve. and the Armature weighted bones have the spline IK Modifier applied in pose mode. everything appears to deform correctly and without issue inside of blender.

I have tried Keyframing only the armature weighted bones, only the target bones, and both together.

enter image description here enter image description here

$\endgroup$
  • $\begingroup$ I was able to add make a short clip of the problem to give a better sense of whats going on. Example Also here is the blend file so anyone can check it out for themselves. Blend File $\endgroup$ – Zachary Nielsen Sep 1 at 2:23
0
$\begingroup$

This may have nothing to do with your problem, but I know Unreal can be very particular about your bone settings, particularly if you have IK bones. If you haven't already, you should go to the Skeleton tab up in the upper right corner and scroll through your Skeleton Tree tab. All the IK bones should be set to 'Animation.' That's the only thing I can think of.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks so much for the comment, I would upvote it but I'm below the 15 points. I tried looking into what you suggested but i cant find anything in Unreal that lets me set bones to Animation? would you mind going into further detail about that? $\endgroup$ – Zachary Nielsen Aug 31 at 18:17
  • $\begingroup$ When you open the Skeleton Tree, click on the drop down menu at the top to toggle your bone options visible (I forget what it's called, but it's the only button there) $\endgroup$ – Ianu Gor Sep 1 at 21:03
  • $\begingroup$ thanks! I was able to find it, they are all set for animation though. I appreciate you trying to help though! $\endgroup$ – Zachary Nielsen Sep 1 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.