0
$\begingroup$

I have a floor and mesh (pen). Im dropping the pen on the floor. Floor is set to passive and pen to active. Added collision-on to floor. When the pen is not dropping on the floor. Its flickering in air. I want to add some few 8-10 pens on the floor so that it get collision with floor and with each. other.Any suggestion how it works.

enter image description here

$\endgroup$
9
  • $\begingroup$ did you try with primitive collision shapes? $\endgroup$ Aug 28 '20 at 5:26
  • $\begingroup$ Try changing the 'floor' plane to a box in the collision setting rather than a mesh. $\endgroup$
    – Chuk
    Aug 28 '20 at 5:29
  • 3
    $\begingroup$ The floating is caused by collision margins set to 4 cm. The pen's shape is problematic, It's too low poly for mesh to work and too misshapen for convex hull. You could try scaling everything up by a factor of 100, too. Physics engine doesn't like small things. $\endgroup$
    – Ron Jensen
    Aug 28 '20 at 6:21
  • 1
    $\begingroup$ @Ron Jensen, is there any need for collision ? Just a rigid body physics will do the job properly right ? $\endgroup$
    – Nxdhin2005
    Aug 28 '20 at 6:23
  • 2
    $\begingroup$ It works for me as Ron Jensen suggested. He pointed all aspects correctly. In this scale I was able to stop moving only with Box. Also it s always good to have Origin in center of Object. @RonJensen please could you write it as answer $\endgroup$
    – vklidu
    Aug 28 '20 at 6:54
5
$\begingroup$

Ok, I tried a few options and got a fairly stable simulation. Here is the result: multiple pens falling and colliding with the ground

Steps:

  • Scale the ground and pen up by 100 (physics simulations work better with larger objects. Also, the floating came from the constant collision margin of 4 cm which means that objects will already collide when they are 2*4 centimeters apart. While this value can be changed, it is better to scale the objects up)
  • Apply the scale on the pen with Ctrl+A > Scale
  • Set the origin of the pen to Center of Mass (Volume) (a wrong origin can mess up simulations)
  • Use convex hull as collision shape (should be precise enough in this case. Mesh shape causes glitches)
  • Use box as collision shape for the ground (except if you want to use a different shape)
  • Finally, you might want to increase the Rigidbody simulation steps (Go to Scene Properties > Rigid Body World and increase Steps per Second and Solver Iterations, e.g. to 600 and 100)
$\endgroup$
2
  • $\begingroup$ Thanks for the answer. If i want the same scale back. How it will work. $\endgroup$
    – atek
    Aug 28 '20 at 12:34
  • 1
    $\begingroup$ Bake sim and parent all pens to Empty. Scale down Empty $\endgroup$
    – vklidu
    Aug 28 '20 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.