0
$\begingroup$

I am trying to do some sculpting but running into a problem with the default clay brush. I can't tell if this is a bug or operating as intended.

Basically, if I use a low strength value, such as 0.200, the brush actually starts subtracting from my mesh, not adding. I want a low strength value but additive sculpting.

Here's a gif that demonstrates what is happening (Excuse the bad compression):

enter image description here

Notice how ADD is selected, but it's actually carving into the mesh.

enter image description here

I would really appreciate any kind of help! Thanks.

$\endgroup$
6
  • $\begingroup$ It's possible you may have accidentally set your normal to inverted. To check, in the material for the object you are trying to sculpt go to the settings of it and turn on backface culling. If you can see inside the object then you will need to flip the normals or set them outside. You can do this by pressing [option + n] or [alt + n]. $\endgroup$ – Nascent Space Aug 26 '20 at 22:19
  • $\begingroup$ Normals are fine. You can actually reproduce the issue with a default sphere, so it's not specific to my mesh. $\endgroup$ – Jay Aug 26 '20 at 22:58
  • 1
    $\begingroup$ I've asked Pablo Dobarro and this is caused by the combination of autosmooth being enabled and a relatively low resolution mesh. This results in the autosmooth displacement being stronger than the effect of the clay brush displacement. Therefore, this is not a bug. I can add this as a proper answer if it solves your problem. $\endgroup$ – Robert Gützkow Aug 29 '20 at 20:11
  • $\begingroup$ That's good information to have and thank you for your response. Unfortunately my mesh isn't really that low resolution, I've subdivided 3-4 times using the multires modifier so it definitely has plenty of geometry to work with yet still cuts negatively into the mesh. I've tried it on a default sphere as well after subdividing several times and again it still cuts negatively into the mesh. I've been able to get around the issue by just simply not using the clay brush, but I'd really like to know if there is a proper way to solve this issue. $\endgroup$ – Jay Aug 29 '20 at 20:57
  • $\begingroup$ I've tested it on the default Icosphere. I needed four levels of subdivisions with the Multires modifier until the mesh density was high enough that the autosmooth didn't overpower the clay displacement with the default settings of the brush. You have to balance the strength of the clay brush and autosmooth depending on how dense the mesh is. The strength of autosmooth can be adjusted in the sidebar Tool > Brush Settings > Autosmooth. $\endgroup$ – Robert Gützkow Aug 29 '20 at 22:02
3
+100
$\begingroup$

The behavior is caused by Autosmooth (Sidebar (N) > Tool > Brush Settings). This setting controls the amount of smoothing that is applied to each brush stroke. In your project the positive displacement of the clay brush is cancelled out by the stronger Autosmooth. The strength of Autosmooth depends both on the factor in the tool settings and the resolution of the mesh. An object will be affected less in its shape the higher the mesh resolution is.

Hence, there are three options to reduce this unintended displacement:

  1. Reduce the strength of Autosmooth.
  2. Increase the strength of the clay brush.
  3. Use a higher number of subdivisions.

The first and second option are the most straight forward solution to the problem. The third option is only listed for completeness, it is likely not desirable to increase the number of subdivisions just to reduce the impact of Autosmooth.

Autosmooth Strength

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.