7
$\begingroup$

I'm exporting a model from Blender into OBJ and MTL files. When I look at the generated MTL file I see that the "Ka" component of the material is all zeros, and there is no information about the reflectance and translucency of the material either. Have a look:

newmtl BigWall
Ns 15.000000
Ka 0.000000 0.000000 0.000000
Kd 1.000000 1.000000 1.000000
Ks 1.000000 1.000000 1.000000
Ni 1.000000
d 1.000000
illum 2

Here the Kd and Ks colours have the correct value (all white) but the Ka is set to black.

I've seen that the illum statement can provide some hints on whether reflectance is used, but it does not give me any coefficients.

So how can I make Blender export the ambient coefficient or an ambient colour to this file? And from where can I take the coefficients of reflectance and translucency?

Thanks.

BTW: I found these similar questions here but they were not answered, I hope to run with better luck:

EDIT: Blender's documentation here claims to be able to export ambient colour and shading settings like transparency.

$\endgroup$
8
$\begingroup$

By default the ambient color is black.

If you change it to something else in Properties > World > Ambient Color, then it works as expected:

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.